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Introduction 

Reality Studio lets you create interactive, panoramic worlds for 
the Web quickly and easily. At the touch of a button, you can 
design walk-throughs of homes, scenes of vacation spots, 
stores and online catalogs with products you can view in 3D 
detail, galleries of viewable art, and much more. 

This manual describes how to use Reality Studio to create 
projects that you can publish on the Web for the CD-ROM 
content. The other components of Reality Studio suite are: 

• Photovista, to stitch digital photos into panoramas 

• Photovista 3D Objects, to create 3D image objects that 
you can rotate to view on all sides 

• Vista Organizer, to manage, edit and share photos, 
video and audio files, and 360° panoramas 

• Zoom Image Server, a limited-license version to deliver 
high-resolution Flashpix images and objects  

• Viewer – Plug-in or Java version, to view Reality Studio 
content 

• vuForge - customizes the look and feel of the iseemedia 
Viewers for your website 

This manual describes how to create projects in Reality Studio. 
For information about using the other components, refer to the 
online documentation on the CD-ROM in the Documentation 
folder. 



Introduction 

 10

USING THIS MANUAL 

This user’s guide contains information you need to install and 
use Reality Studio. The first two chapters take you through the 
installation and the beginning steps of creating a project. Later 
chapters describe how to add and link elements in your project, 
and give some advanced techniques for experienced Web 
designers. 

• Chapter 1, “Getting Started” - includes system 
requirements, installation instructions, and an overview 
of the Reality Studio application, menus, and toolbars. 

• Chapter 2, “Using Reality Studio Features” – describes 
the parts of a Reality Studio project, how to work with 
assets in the Asset Browser, the different view modes, 
and detailed information about the main application 
features. 

• Chapter 3, “Creating and Previewing a Sample Project” – 
provides five lessons as a quick, hands-on introduction 
to using Reality Studio. 

• Chapter 4, “Working with Elements” – describes the 
types of elements you can add to your projects and how 
to add, size, position, and edit elements in Flat, 3D, and 
Overlay mode. 

• Chapter 5, “Linking Vistas and Elements” – describes 
how to create links between vistas, and link elements to 
URLs and other HTML pages. 

• Chapter 6, “Publishing Your Project” – describes how to 
export your project files to publish your finished project 
on the Web or to a CD target. This chapter will also 
explain how to upload your project to the Zoom Image 
Server. 
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• Chapter 7, “Behind the Scenes” – presents an overview 
of Virtual Reality Modeling Language (VRML) and the 
iseemedia extensions to VRML 2.0, and provides 
advanced techniques for editing the IVR files that Reality 
Studio exports. 

• Appendix A, “Troubleshooting” – provides answers to 
typical situations that might occur while working in 
Reality Studio. 

• The Glossary provides definitions of terms using in this 
book and in Reality Studio. 

VIEWING THE ONLINE TUTORIAL 

The ideal way to get tips for working with Reality Studio is to 
work through the online tutorial, which has features that are 
useful to novice and expert Web designers. The online tutorial 
can be accessed from the CD-ROM or directly from the 
iseemedia website at www.iseemedia.com. 

USING THE ONLINE HELP 

The online Help is designed to give you concise information that 
you can access quickly while you’re working. 

To access the online help 

From the Help menu, choose Help Topics. 

GETTING TECHNICAL SUPPORT 

The first place to look for solutions is Appendix A, 
“Troubleshooting.” For the most current information and 
answers to frequently asked questions (FAQs), visit the 
iseemedia website at www.iseemedia.com.
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Chapter 1: Getting Started 

This chapter will help get you started using Reality Studio by 
providing system requirements and installation instructions. 
After you install Reality Studio, take a few minutes to read 
through the rest of this chapter for an overview of Reality 
Studio, including descriptions of: 

• The main features, which let you achieve a wide variety 
of effects using vistas, links, and other project elements 

• The components of the application that you use to build 
your projects: Viewport, Project Manager, Asset 
Browser, and World Map 

• The menu commands, keyboard shortcuts, and toolbar 
buttons 

SYSTEM REQUIREMENTS 

Before you install Reality Studio, make sure you have at least 
the minimum system requirements. This will ensure that you 
get the best performance from your software. 

Note: These requirements are for the Reality Studio application 
only. For the hard disk space and RAM requirements for 
additional components in the suite, refer to the documentation 
for each component on your Reality Studio CD-ROM. 

• Pentium III 500 MHz 

• Windows 2000 SP3 or higher or Windows XP 

• 150 MB hard disk space for the minimal install; 200 MB 
for the full install (additional space is required to store 
your project) 
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• 256 MB RAM required. more RAM is recommended 
depending on the content that is being used (e.g. 
movies with a high frame rate, and complex VRML 
geometry) 

• Netscape Navigator® 7.1; Microsoft Internet Explorer® 
5.0; Netscape Communicator® 4.78 

• Java Virtual Machine (available from the CD-ROM) 

• DirectX 9.0b (available from the CD-ROM) 

• QuickTime 6.3 

• Adobe Photoshop® 7.0 (required for the Plug-in Effects) 

INSTALLATION INSTRUCTIONS 

The Reality Studio CD includes the installation of all the 
components that accompany Reality Studio. Once you insert 
the CD into the CD-ROM or DVD-ROM drive, the installation will 
begin. Select the components you would like to install. In order 
to install all the components, you must return back to the main 
installation screen and select the next component you wish to 
install. For each component, follow the on-screen installation 
instructions. 

Note: Not all components included on the CD are installed 
through the main installation screen. The following components 
can be found by selecting the Browse button on the main 
installation screen or from your Windows Explorer window: 

• vuForge – located in the vuForge folder 

• DirectX – located in the Third Party folder 

• Java Virtual Machine – located in the Third Party folder 
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• Documentation – includes the user guides for Photovista 
3D Objects, Photovista Panorama, Reality Studio, 
vuForge and the Zoom Image Server 

• Tutorial – a tutorial based on the main components of 
Reality Studio 

REALITY STUDIO FEATURES 

Reality Studio makes it easy for you to create and manage your 
projects, while helping you enhance your websites with a 
variety of rich effects. Using the range of features, you can: 

• Link vistas together to create dynamic environments 
that site visitors can "walk" through. 

• Link vistas and project elements to URLs to provide 
related information on the Web and in other HTML 
pages. 

• Add images, movies, sounds, and image objects to 
panoramas in Flat, 3D, and Overlay modes for a 
variety of uses, including voice-over narratives and 
objects you can manipulate to view on all sides and 
from different perspectives. 

• Program actions to show, hide, toggle, play, loop, 
and stop elements and multimedia by adding 
multilink actions to your hotspots. 

• Save working project files and create a group of 
exported files for publishing on the Web in plug-in or 
Java applet form. 

• Preview your project in an internal viewer or in an 
HTML page running the Viewer to help you as you 
design your interactive world. 
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• Apply plug-in effects to your images, image objects 
and vistas 

• Export your world map to HTML so it can be viewed 
in a web browser for navigational purposes. 

• Export your project to the CD ready format.  

• Link vistas together and display a web page when 
clicking on a hotspot. 

• Java Viewer now includes a customizable control 
panel. 

• Easy to use user interface that includes resizable 
windows, dockable panes and 4 toolbars. 

• Upload your project either to a remote or local Zoom 
Image Server. 
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REALITY STUDIO COMPONENTS 

The main window comprises of the Viewport and dockable 
panes that you can size and position independently as you 
work. You can also hide or show a status bar at the bottom of 
the main window. 

 

 

VIEWPORT 

The Viewport is your main working area and displays the vistas 
in your project in scrollable windows that you can minimize and 
maximize as you work. The vista windows have three view 
modes that you switch between to add elements to your 
project. 

Project 
Manager 

Asset 
Browser 

Status 
Bar 

Viewport 

World 
Map 



Chapter 1: Getting Started 

 17

The following table describes the three view modes and their 
functions: 

View 
mode 

Function 

Flat 

Add, position, and size panels (images and movies) 
and hotspots in the panoramic space. For example, you 
could have a photo on a wall that is only visible when 
you pan into that portion of the panorama. 

3D 

Place 3D elements into a vista and position them in the 
3D space. For example, you could have an image 
object (IMOB) of a camera that you can rotate to view 
on all sides. 

Overlay 

Place elements on top of the vista in groups and layers. 
For example, you could have a group of photos that 
appears when you click a button and disappears when 
you click it again. When you pan and zoom in the vista, 
the overlay elements do not shift out of view. Overlay 
mode is often used to make interfaces for a tour, or 
pop-up navigation maps. 

 

Note: For more information about the view modes, see Chapter 
4, “Working with Elements”, on page 61. 

ASSET BROWSER AND ASSET COLLECTIONS 

Assets are media files that have been prepared for use in 
Reality Studio. The Asset Browser organizes all of the assets 
available to your projects, using tabs that make it easy for you 
to switch back and forth between the different types of assets. 

Reality Studio comes with a set of iseemedia assets and some 
collections from third-party vendors. You can also create asset 
collections from directories of media files on your hard drive. 
The asset collections appear in folders in the left pane of the 
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Asset Browser and thumbnail images, when available, appear in 
the Preview pane on the right. The middle pane shows the 
available assets, represented by icons. 

The asset icons act as links to the media files on your hard 
drive. You drag these links from the Asset Browser into your 
vistas to create elements in your project. For more information, 
see “Using the Asset Browser”, on page 34. 

PROJECT MANAGER 

The Project Manager shows a list of the elements contained 
within each scene in your project, organized in expandable 
folders as in a standard Windows Explorer directory. The top 
level folder is your project, with folders below for each vista. 
Each vista folder contains a Flat, 3D, and Overlay folder. These 
folders correspond with the three view modes and organize the 
elements in your project. For more information, see “Using the 
Project Manager”, on page 40. 

WORLD MAP 

The World Map shows a schematic representation of all of the 
scenes in your project, with each one appearing as a round 
node on a plane. Using the World Map, you can link vistas, view 
links between vistas, and get an overview of your project. For 
more information, see “Using the World Map”, on page 42. 

MENUS 

This section gives you an overview of the main menu 
commands and keyboard shortcuts. 
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FILE MENU 

The following table describes the File menu commands and 
keyboard shortcuts. 

Command Description Keyboard 
Shortcut 

New Prompts to save, then closes the 
current project to start a new one 

CTRL + N 

Open Opens an existing Reality Studio 
project (RSD file). 

CTRL + O 

Close Project Closes the current project. If 
closing for the first time, prompts 
for a name and location to save 
the project as an RSD file. If there 
are unsaved changes, prompts to 
Save before closing. 

 

Save Saves your project as an RSD file. CTRL + S 

Save As Saves a copy of the RSD file (with 
a different name or location). 

 

Revert Reverts to the previously saved 
version of your RSD file, 
eliminating any unsaved changes. 
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Command Description Keyboard 
Shortcut 

Assets 

Up Folder 

Refresh 

Add 
Collection 

Remove 
Collection 

 

• Moves up one level to the next 
folder. 

• Refreshes the Asset Browser 

• Adds an asset collection to the 
Asset Browser. 

• Removes the selected asset 
collection from the Asset 
Browser. 

 

Export 

Plug-in 
Target 

Java Applet 
Target 

CD Ready 
Target 

 

Exports your project to an IVR and 
HTML file. You can choose to 
export the HTML with a plug-in 
target, Java applet or to the CD 
Ready Target format. 

 

Preview 

Quick 

Browser 

 

• Quick preview plays your 
project in the internal viewer. 

• Browser preview plays your 
project in an HTML page using 
the Plug-in Viewer. 
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Command Description Keyboard 
Shortcut 

Upload to 
Server 

Prepares your files for upload to 
the Zoom Image Server 

 

Recent File List Lists the recently opened project 
files. 

 

Exit Prompts to save, then exits.  

 

EDIT MENU 

The following table describes the Edit menu commands and 
keyboard shortcuts. 

Command Description Keyboard  
Shortcut 

Undo Undoes the most recent edit CTRL + Z 

Insert 

Vista 
Hotspot 
Panel 
Geometry 
Sound 
URL 

Inserts an element or hotspot into 
the project, or browses for a URL 
link to insert. 

 

Delete 
Deletes the selected element in 
the project. 

Delete 

Properties 
Shows the Properties dialog box 
for the selected element in the 
Viewport or Project Manager 
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Command Description Keyboard  
Shortcut 

Launch Editor 
Launches the associated editing 
application in the Viewport or 
Project Manager. 

 

 

VIEW MENU 

The following table describes the View menu commands and 
keyboard shortcuts. 

Command Description Keyboard 
Shortcut 

Vista 

Flat 
3D 
Overlay 

 

Sets the view mode in the current 
vista in the Viewport. For a 
complete description of the view 
modes, see Chapter 4, “Working 
with Elements”, on page 61. 

 

Toolbar 

Project 
Vista 
Export 
Project 
Insert 
Objects 

Shows or hides each toolbar. For a 
complete description of each 
toolbar, see “Toolbars” on page 
25. 

 

Zoom in 
In Flat mode, decreases the field of 
view. 

 

Zoom out 
In Flat mode, increases the field of 
view. 
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Command Description Keyboard  
Shortcut 

Pause 
Pauses all the multimedia present 
in your project. 

 

Project 
Manager 

Shows or hides the Project 
Manager. 

 

Asset Browser Shows or hides the Asset Browser  

World Map Shows or hides the World Map.  

Status Bar Shows or hides the Status Bar.  

TOOLS MENU 

The following table describes the Tools menu commands and 
keyboard shortcuts. 

Command Description Keyboard 
Shortcut 

Photovista 
Panorama 

Launches Photovista Panorama, 
which you use to create digital 
panoramas. 

 

Photovista 3D 
Objects 

Launches Photovista 3D Objects, 
which you use to create and edit 
3D image objects (IMOBs). 

 

Apply Plug-in 
Effects 

Launches the Plug-in Effects dialog 
box. 
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WINDOW MENU 

The following table describes the Window menu commands and 
keyboard shortcuts. 

Command Description Keyboard 
Shortcut 

Cascade 
Displays the open windows in 
cascade style. 

 

Tile 
Displays the open windows as 
tiles. 

 

Arrange Icons Organizes the minimized windows.  

Close all  
Closes all the vista windows in the 
Viewport. 

 

Open Vista List 
Lists the open vistas in the 
Viewport. 

 

HELP MENU 

The following table describes the Help menu commands and 
keyboard shortcuts. 

Command Description Keyboard 
Shortcut 

Help Topics Launches the online Help system. F1 

iseemedia 
Home Page 

Launches your default Web browser 
to show the iseemedia home page. 
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Command Description Keyboard 
Shortcut 

Online Toolbox 

Launches your default Web browser 
and displays the Online Toolbox 
that includes downloads available 
for Reality Studio. 

 

About Reality 
Studio 

Shows version and copyright 
information about Reality Studio. 

 

 

TOOLBARS 

Reality Studio has four main toolbars that let you quickly 
accomplish tasks, without using menu commands. When you 
first launch Reality Studio, these toolbars appear at the top of 
the main window: 

• Project toolbar for standard tasks, such as opening and 
saving projects 

• Vista toolbar for changing view modes, adding hotspots, 
zooming in and out, and pausing multimedia 

• Export Project toolbar for exporting your project to the 
Plug-in Viewer, the Java Viewer or to the CD Ready 
Target. 

• Insert Objects toolbar for inserting elements to your 
project. 

Note: For a description of the toolbar attached to the Asset 
Browser, see “Using the Asset Browser”, on page 34. 
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You can choose to show or hide these toolbars in the Reality 
Studio main window or use them as individual, floating panes. 
Double-click the toolbar to switch between docking and floating. 

PROJECT TOOLBAR 

Use the Project toolbar to open, close and create new projects, 
to preview your project, and to perform editing tasks. The 
following table shows the Project toolbar buttons and describes 
their actions. 

Button Action 

New 

 

Closes the current project to start a new one. 

Open 

 

Opens an existing RSD file. 

Save 

 

Saves your project as an RSD file. 

Quick Preview 

 

Plays your project in the internal viewer. 

Browser Preview 

 

Creates temporary files that play your project 
in the Plug-in Viewer. 

Delete 

 

Deletes the selected element. 

Toggle Project 
Manager 

 

Shows or hides the Project Manager. 
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Button Action 

Toggle Asset 
Browser 

 

Shows or hides the Asset Browser. 

Toggle World Map 

 

Shows or hides the World Map. 

Help 

 

Launches the online Help. 

 

VISTA TOOLBAR 

Use the Vista toolbar to change view modes, add hotspots, 
zoom in and out, and move and size elements in your vistas. 
The following table shows the Vista toolbar buttons and 
describes their actions. 

Button Action 

Scroll 

 

Lets you scroll open vistas. 

Add Hotspot 

 

Add hotspots into the current vista. 

Flat View 

 

Changes the view mode to Flat. 

3D View 

 

Changes the view mode to 3D. 
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Button Action 

Overlay View 

 

Changes the view mode to Overlay. 

Zoom in 

 

Decreases the field of view. 

Zoom out 

 

Increases the field of view. 

Pause 

 

Pauses the multimedia (movie or sound). 

 

EXPORT PROJECT TOOLBAR 

Use the Export Project toolbar to change export your project to 
the three different modes. The following table shows the Export 
Project toolbar buttons and describes their actions. 

Button Action 

Plug-in Export 

 

Prepares all the files you need to export to the 
Plug-in Viewer. 

Java Viewer Export 

 

Prepares all the files you need to export to the 
Java Viewer. 

CD Ready Target 
Export 

 

Prepares all the files you need to produce a CD 
containing your project. 
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Button Action 

Upload to the 
Zoom Image 
Server 

 

Prepares all the files you need to upload your 
project to either a remote or local Zoom 
Image Server. 

INSERT OBJECTS TOOLBAR 

Use the Insert Object toolbar to insert various elements to your 
project. The following table shows the Insert Objects toolbar 
buttons and describes their actions. 

Button Action 

Insert Vista 

 

Inserts a vista into your project. 

Insert Hotspot 

 

Inserts a hotspot into your project. 

Insert Panel 

 

Inserts a panel (video or image) into your 
project. 

Insert Geometry 

 

Inserts a geometry object into your project. 

Insert Sound 

 

Inserts a sound file into your project. 

Insert URL 

 

Inserts a URL link into your project. 
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Chapter 2: Using Reality Studio Features 

Think of each finished Reality Studio project as a world 
consisting of various scenes with elements, such as photos on a 
wall and hotspot links to other scenes. The background for each 
scene is a panoramic image with field of view information, 
called a vista. For example, you might want to create a tour of 
a tropical island, including different locations, such as a hotel, 
beach, and marketplace. Your project is the whole island and 
each scene is one of the island locations. Some of the elements 
you can add to your scenes include images and movies, links to 
other locations, musical and narrative sounds, and objects you 
can rotate to view on all sides, such as merchandise for sale in 
the marketplace. 

 

The sections in this chapter include: 

• An overview of the assets and elements you can add to 
your Reality Studio projects 

• An introduction to Flat, 3D, and Overlay mode 



Chapter 2: Using Reality Studio Features 

 31

• A description of using the Asset Browser to add 
elements to your project and manage asset collections, 
and the media types Reality Studio supports 

• A description of using the Project Manager to organize 
the vistas and elements in your project 

• A description of using the World Map to get an overview 
of the vistas and inter-vista links in your project 

ABOUT ASSETS AND ELEMENTS 

Assets are media files (such as images, sounds, and movies) 
that you add to Reality Studio to create elements in your 
projects. You can drag media files from your local directories 
into your projects, or use the asset collections that come with 
Reality Studio. The following table describes the types of assets 
you can use: 

Asset Description 

Frames A rectangular picture frame image used as a 
border around the iseemedia Viewer. 

Geometry 3D object represented by geometric primitives 
and texture maps. 

Image Objects 
(IMOBs) 

A series of photographic images of a real-world 
3D object, taken from various angles. During 
playback, you can manipulate the IMOB to 
change which image displays. This simulates the 
experience of examining an actual 3D object. 

Note: You can create IMOBs using Photovista 
3D Objects, which is included in the Reality 
Studio suite. 

 



Chapter 2: Using Reality Studio Features 

 32

Asset Description 

Panels 

Images 
Movies 

Rectangular objects that you can position and size in 
three view modes (Flat, 3D, Overlay). 

• In Flat mode, you can warp the panel to conform 
to the contours of the vista; the panel remains 
fixed in its position and moves out of view when 
you pan. 

• In 3D mode, you can position the panel in 3D 
space. 

• In Overlay mode, you place the panels on top of 
the vista and they remain visible on the screen 
no matter where you pan. 

Sounds Audio-samples media files. 

• Point-source sounds vary in volume according to 
proximity in the view. You can add point-source 
sounds in 3D mode. 

• Ambient sounds have the same volume 
regardless of your position in the view. You can 
add ambient sounds in Overlay mode. 

Vistas Panoramic backgrounds for the scenes in your 
project; a new VRML ExternProto node created by 
iseemedia as an extension to VRML 2.0. You can use 
IVR files created by Photovista that use standard or 
Flashpix images. 
Note: When you use an IVR file that has multiple 
vista nodes, Reality Studio reads the first vista in the 
file and disregards the rest. 

URL Links URL links can be added to your project for directly 
linking a hotspot to a web page. 
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When you place an asset into your project and it becomes an 
element, the basic media file of the asset does not change. 
However, the element acquires additional attributes that 
describe how it is used in the project, such as a position in the 
panoramic, screen, or 3D space. 

Note: For details about adding elements to your projects and 
working with then in Flat, 3D, and Overlay modes, see Chapter 
4, Working with Elements” on page 61. 

ABOUT THE VIEW MODES 

The view modes correspond to different spatial areas in your 
vistas and the attributes of an element depend on where you 
place it in that space. The active view mode in the vista window 
determines the type of elements you can add.  

Note: You can only change view modes when a vista is open in 
the Viewport. 

The three view modes are: 

• Flat —places elements, such as images, movies and 
URLs, into the panoramic space; the elements appear 
attached to a fixed place on the vista, moving in and out 
of view as you pan the vista. 

• 3D—places elements, such as image objects (IMOBs) 
and sounds, in 3D space; the perspective of the 
elements changes as you navigate the vista. 

• Overlay—places elements, such as images and sounds, 
on top of the vista in the screen space; the elements 
remain visible on the viewer screen no matter where 
you navigate in the vista. 
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CHANGING THE VIEW MODES 

As you work in Reality Studio, you’ll be switching view modes 
often to add, size, and position elements in your vistas. 

• From the View menu, choose Vista > Flat or click the 
toolbar icon to add images, movies, and hotspots to the 
panoramic space. 

• From the View menu, choose Vista > 3D or click the 
toolbar icon to add and view images, movies, sounds, 
image objects (IMOBs), and geometry objects in the 3D 
space. 

• From the View menu, choose Vista > Overlay or click the 
toolbar icon to add images, movies, IMOBs, and sounds 
onto the screen space. 

Note: For details about using the three view modes to add 
elements to your projects, see Chapter 4, “Working with 
Elements” on page 61. 

USING THE ASSET BROWSER 

The Asset Browser organizes all of the asset collections and 
makes it easy for you to drag assets into your projects. The left 
pane of the Asset Browser shows the asset collections, the 
middle pane shows asset icons that act as links, and the right 
pane shows a thumbnail preview of a selected asset, when 
available. Tabs show the types of assets in the collection, such 
as images, movies, and sounds. Each tab represents a 
subfolder in a main directory of media files. 
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The following table describes how to view the asset collections: 

To do this Use this procedure 

Select an asset collection to 
view 

Scroll through the asset collection 
icons, then, click the collection you 
want to view. The asset tabs and 
icons appear. 

Switch between asset types Click the tabs below the asset icons 

View a thumbnail preview of 
an asset 

Click the asset icon. The thumbnail 
appears in the right pane of the 
Asset Browser. 

 

ASSET TOOLBAR 

An Asset toolbar appears below the thumbnail preview pane in 
the Asset Browser. The following table describes the buttons in 
the Asset toolbar and their actions: 

Button Action 

Back 

 

Returns to the previous location; if 
you switched asset tabs, this will 
return you to the previous tab. 

Refresh 

 

Refreshes the Asset Browser 
contents. 

Add Collection 

 

Browses for a local folder to add an 
asset collection. 

Remove Collection 

 

Removes the selected asset 
collection. 
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When you launch Reality Studio, the Asset Browser appears. 
You can hide the Asset Browser if you want more space to work 
on your scenes. You can also undock the Asset Browser to use 
it as a floating pane. 

To show or hide the Asset Browser: 

• From the View menu, choose Asset Browser or click the 
toolbar icon. The Asset Browser appears (if it was 
hidden) or disappears (if it was showing). 

To undock and dock the Asset Browser: 

• To undock the Asset Browser, double-click one of its 
outer edges to release it to a floating pane. You can also 
click and drag to move the Asset Browser out of the 
main window to a floating pane. 

• To dock a floating Asset Browser pane, drag it to the 
bottom edge of the Reality Studio main window and 
release the mouse button. 

Note: When moving a floating pane, press CTRL as you drag to 
prevent it from docking. 

 

CREATING CUSTOM ASSET COLLECTIONS 

Reality Studio comes with an iseemedia asset collection and 
some collections from third-party vendors. Most likely, you’ll 
want to add custom asset collections from your local directories 
of media files, such as the panoramas you generate using 
Photovista or the 3D image objects you create in Photovista 3D 
Objects. 
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When you add an asset collection, a tab appears in the middle 
pane of the Asset Browser for each subfolder in the directory of 
media files. For example, if your directory is named Model 
House and the subfolder of panorama files is named Rooms, 
the asset collection will be Model House and the tab you see in 
the middle pane of the Asset Browser will be Rooms. 

Note: If there are no subfolders in the directory you added as 
an asset collection, the assets appear in the middle pane of the 
Asset Browser, but no tabs will appear below them. 

To create a custom asset collection: 

1. In the Asset toolbar, click Add Collection. The Browse for 
Folder dialog box appears. 

2. Navigate to the folder that contains the media files you 
want to add to the Asset Browser and click OK. The new 
asset collection icon appears in the left pane of the Asset 
Browser and the media files appear as icons in the 
middle pane. 

SUPPORTED MEDIA TYPES 

For creating assets, Reality Studio supports media types that 
the Viewers can display. The media types include Flashpix™, a 
digital image file format that lets you zoom in to high-level 
detail in your images. 

The following table describes the supported media types: 

Media type Description 

AIFF (Audio Interchange File Format) A digital audio file 
format from Apple that is used on the Macintosh. 

Animated GIF An animation created from a Graphics Interchange 
Format (GIF) image. 
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Media type Description 

AU (Audio File) A digital audio file format from Sun 
that is used on the Internet and can be played by 
a Java program. 

AVI Microsoft’s Audio/Video format. You can use these 
files as movie panels. 

BMP (Bitmap) A pixel-based image file format that you 
can use for image panels or panoramas. 

FPX (Flashpix) A digital image file format that lets you 
view a screen resolution of an image and zoom in 
for high levels of detail. You can use Flashpix 
images for vistas and image objects (IMOBs). The 
Zoom Image Server is necessary to view Flashpix 
images. 

GIF (Graphics Interchange Format) A popular Internet 
format for 256 color images; best suited for icons, 
logos, and diagrams. GIFs are usually smaller file 
sizes that display well even over low-bandwidth 
Internet connections. 

JPEG (Joint Photographic Expert Group) A pixel based 
image format that has ability to be compressed. 

MIDI (Musical Instrument Digital Interface) A standard 
protocol for the interchange of musical information 
between musical instruments, synthesizers and 
computers. 

MP3 (MPEG Audio Layer 3) An audio compression 
technology that is part of the MPEG-1 and MPEG-2 
specifications.  

MPEG1 and 
MPEG4 

(Moving Pictures Experts Group) An ISO/ITU 
standard for compressing video. 
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Media type Description 

QuickTime QuickTime Apple Computer's Audio/Video format. 
You can use these files as movies, sounds, 
panoramas, or slide shows. 

Note: To use these files, you must have 
QuickTime installed on your computer. 

WAV (Waveform) A Windows standard audio file format. 

 

Using Flashpix 

Flashpix is a hierarchical image file format that provides multi-
resolution imaging for fast, realistic presentations on CD-ROMs 
and the Internet. You can view the image at one resolution on 
your computer screen and zoom in to higher resolutions to see 
greater levels of detail. Flashpix works with the Zoom Image 
Server to deliver high-quality image performance over low 
bandwidth for the Internet. 

Using Flashpix in your Reality Studio projects adds greater 
depth to your finished worlds. For example, if use a Flashpix 
image as a picture on a wall in a vista, you can zoom in to view 
small details in the picture. When you use a Flashpix image 
object (IMOB) created using Photovista 3D Objects, you can 
examine the object on all sides and zoom in to view minute 
features, such as text on a label. Flashpix vistas created using 
Photovista let you zoom in to see details like patterns on a floor 
tile. For more technical information about Flashpix, see the 
Glossary on page 133. 

The next section introduces the Project Manager, which 
organizes your project vistas and elements as you work. 
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USING THE PROJECT MANAGER 

The Project Manager is a hierarchical representation of the 
vistas and elements in your project. Each time you add a new 
vista, a group of folders appears; these folders organize all of 
the elements and hotspot links that you add in Flat, 3D, and 
Overlay mode. 

You can drag vistas into the Project Manager from the Asset 
Browser to add new vistas to your project. When you add a 
vista to the Project Manager, it opens in the Viewport. The 
currently selected vista or element in the Viewport is always 
highlighted in the Project Manager. 

 

• To expand or collapse a folder, click on the + or - sign in 
front of the folder, or double-click the folder. 
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• To edit the properties of the project or an element, 
right-click the project folder or the element you want to 
edit and choose Properties from the shortcut menu. A 
Properties dialog box appears for you to edit the 
attributes. 

• Right-click a vista or an element to show a shortcut 
menu, then choose a command to: 

o Change the view mode for the vista 

o Delete the vista or element 

o Launch an editing application for that media type 

o View the vista or element properties 

• To display a vista on top of the other open windows in 
the Viewport, click the vista you want to view. 

When you launch Reality Studio, the Project Manager appears 
docked to the left side of the main window. You can dock the 
Project Manager to the right side if you prefer, or undock it to 
use it as a floating pane. 

To show or hide the Project Manager: 

• From the View menu, choose Project Manager or click 
the toolbar icon. The Project Manager appears (if it was 
hidden) or disappears (if it was showing). 

To undock and dock the Project Manager: 

• To undock the Project Manger, double-click one of its 
outer edges to release it to a floating pane. 
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• To reposition the Project Manager or dock it when it’s 
floating, drag it to the right or left edge of the Reality 
Studio main window and release the mouse button. 

Note: When moving a floating pane, press CTRL as you drag to 
prevent it from docking. 

USING THE WORLD MAP 

The World Map represents the entire project schematically, with 
each scene displayed as a round node on a plane. This overview 
helps you organize and keep track of the many vistas in your 
projects. You can add a new vista and place it in relationship to 
the other vistas in your project. 

Each time you add a vista to your project, a new round node 
appears in the World Map. Using the World Map you can: 

• To show the vista name, pass the pointer over a node. 

• To select a node and show any links to other vistas, 
double-click the node. That vista appears in the 
Viewport and appears selected in the Project Manager, 
as well. 
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To show or hide the World Map 

• From the View menu, choose World Map or click the 
toolbar icon. The World Map appears (if it was hidden) 
or disappears (if it was showing). 

To dock and undock the World Map: 

• To dock a floating World Map pane, drag it to the bottom 
edge of the Reality Studio main window and release the 
mouse button. 

• To undock the World Map, double-click one of its outer 
edges to release it to a floating pane. 

Note: When moving a floating pane, press CTRL as you drag to 
prevent it from docking. 

Setting the background image 

The default background for the World Map is a grid, which gives 
spatial reference to the vistas in your project. You can set a 
different background image, as well. For example, if you’re 
creating a real estate walk-through, you might choose a 
blueprint image of the house as the background image for the 
World Map. This gives you an overview of the vistas of each 
room and the links between them. 

To change the background image: 

• Drag an image from the Asset Browser or your desktop 
into the World Map. To save this image to the World 
Map, from the File menu, choose Save. 
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Now that you understand the basics about Reality Studio 
projects, take some time to follow the online tutorial lessons or 
the lessons in Chapter 3, “Creating and Previewing a Sample 
Project”. The online tutorial is on your Reality Studio CD-ROM 
or from the iseemedia website.
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Chapter 3: Creating and Previewing a Sample Project 

These five short lessons give you a quick, hands-on 
introduction to using Reality Studio. The lessons in this chapter 
use some of the vistas, images, sounds, and objects that are in 
the online tutorial on your Reality Studio CD-ROM. 

• Lesson 1 covers adding vistas to start your project, after 
which you’ll save it. 

• Lesson 2 shows you how to link your vistas using the 
drag-and-drop method and the hotspot button. 

• Lesson 3 guides you through adding elements in Flat, 
3D, and Overlay mode, including setting some element 
properties. 

• Lesson 4 describes how to assign an action to an 
element and trigger events. 

• Lesson 5 details how to preview your project in the Plug-
in Viewer and interact with the links and elements you 
added in the first four lessons. 

Note: For a more in-depth overview of the sophisticated effects 
you can create in a Reality Studio project, view the online 
tutorial. The tutorial is on your Reality Studio CD-ROM or can 
be downloaded from the iseemedia website. 

LESSON 1: ADDING VISTAS AND SAVING YOUR PROJECT 

Starting a Reality Studio project is as simple as adding some 
vistas to the Viewport or Project Manager to create the first 
scenes. You can add vistas from the Asset Browser or your 
desktop files. For this lesson you’ll be using the Caribbean 
Resort asset collection. 
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ADDING VISTAS 

1. Launch Reality Studio from the Windows Start menu by 
choosing Programs > iseemedia > Reality Studio. 

2. Show the Caribbean Resort asset collection by clicking 
the Caribbean Resort icon in the left pane of the Asset 
Browser. The Vista tab appears by default. 

 

3. Drag the Private Suite vista from the Asset Browser into 
the Viewport. You’ll see a vista folder appear in the 
Project Manager as the vista opens in the Viewport in 
Flat mode. The Flat, 3D, and Overlay folders appear 
within the vista folder. 

 



Chapter 3: Creating and Previewing a Sample Project 

 47

4. Next, drag the Beach vista and the Market vistas from 
the Asset Browser into the Project Manager. You should 
see three vista folders in the Project Manager, named 
Private Suite, Beach, and Market. 

5. Bring the Private Suite vista to the front in the Viewport 
by clicking the vista icon in the Project Manager. You can 
also press CTRL + Tab to switch between open vistas in 
the Viewport. 

6. Maximize the vista window by clicking the Maximize 
button in the upper right corner of the window. 

You’re set to proceed to “Lesson 2: Linking vistas,” but first 
you’re going to save your project. 

 

SAVING YOUR PROJECT 

When you save your project, Reality Studio creates an RSD 
project file. This is your working project file, which you will later 
export along with the associated media files. When you save, 
you set the name of your project that appears in the Project 
Manager. 

1. From the File menu, choose Save or click the toolbar 
icon. The Save As dialog box appears. 

2. Navigate to the folder where you want to save your 
project files. 

3. Type a name for your project in the File Name field and 
click OK to save your project. 
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LESSON 2: LINKING VISTAS 

When you create links between vistas, you’re setting up the 
navigation for your project. In this step, you’ll use two different 
methods for linking vistas: adding a hotspot link and dragging a 
vista from the Project Manager into the Viewport. Proceeding 
from Lesson 1, the Private Suite vista should now be open and 
maximized in the Viewport. 

LINKING VISTAS 

1. To insert a hotspot link between vistas, do one of the 
following: 

• From the Edit menu, choose Insert > Hotspot. 
The Hotspot Properties dialog box appears. 

• Click the Hotspot button in the Vista toolbar, then 
click the Private Suite vista in the Viewport and 
drag to size the hotspot. When you release the 
mouse button, the Hotspot Properties dialog box 
appears. 

 



Chapter 3: Creating and Previewing a Sample Project 

 49

2. In the Element Name field, type “To Beach”. 

3. Click the Vista Link option and from the Destination 
drop-down list, choose Beach. 

4. Click Transition. The Link Transition dialog box appears. 

 

5. Set the exit view for Private Suite and the entry view for 
Beach by clicking on each vista and panning until you 
see the view you want. The pitch and yaw values change 
as you pan. For this lesson, leave the field of view 
settings as they are. 

Note: For more information about pitch, yaw, and field 
of view, see “Setting the link transition” on page 100. 

6. From the Transition Type drop-down list, choose Pan 
and Zoom. Leave the Duration set to 1 second, which is 
the amount of time it will take for the link transition. 

7. Click OK to close the Link Transition dialog box, then 
click OK to close the Hotspot Properties dialog box. In 
the Viewport, you’ll see a tracker with corner handles for 
the link. In the Project Manager, you’ll see the hotspot in 
the Flat folder within the Private Suite folder. 
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8. Bring the Beach vista to the front in the Viewport by 
selecting its icon in the Project Manager. 

9. Drag the Market vista icon from the Project Manager 
onto the Beach vista in the Viewport. The Link Transition 
dialog box appears. 

10. Repeat steps 5 and 6 above to finish linking the Market 
vista to the Beach vista. You’ll see the link in the Project 
Manager in the Flat folder within the Beach folder. 

11. To name this link, right-click the link in the Project 
Manager or double-click the link in the Viewport. The 
Hotspot Properties dialog box appears. 

12. In the Element Name field, type “To Market” and click 
OK. 

13. From the File menu, choose Save to save your work. 

In the Project Manager, you should now see a vista link in the 
Flat folders within the Private Suite folder and the Beach folder. 
Lesson 3 describes how to add some elements to your vistas in 
Flat, 3D, and Overlay mode. 

LESSON 3: ADDING ELEMENTS IN FLAT, 3D, AND OVERLAY 

MODE 

Things get really exciting when you add elements to your 
scenes. The three view modes let you place elements into 
different spatial areas of your vistas. In this lesson, you’ll add: 

• A movie panel to the TV screen in the Private Suite vista 
in Flat mode 

• Two IMOBs of tourists to the Beach vista in 3D mode 
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• An IMOB of a Kalimba, the sound of Kalimba music, and 
a starfish image panel to the Market vista in Overlay 
mode 

FLAT MODE 

When you place elements in Flat mode, they appear as if they 
are stuck to the surface of the panorama and move out of view 
as you pan your vista. In this section, you’ll place a movie onto 
the TV screen in the Private Suite vista, then you’ll view it in 3D 
mode. 

Note: In Flat mode, you see only the element’s tracker; to view 
the image content for flat elements, you need to switch to 3D 
mode. 

To add an element in Flat mode: 

1. Bring the Private Suite vista to the front in the Viewport 
by clicking its icon in the Project Manager. Then click the 
vista and drag the pointer to pan to the right until you 
see the TV. 

2. Make sure the Caribbean Resort asset collection appears 
in the Asset Browser by clicking its icon in the left pane 
of the Asset Browser. 

3. Click the Movies tab and drag the TV movie icon onto 
the TV. The tracker appears quite a bit larger than the 
TV screen. 

4. Drag the corner and side handles of the movie tracker to 
size it to the TV screen. 

5. Click the 3D button in the Vista toolbar to switch to 3D 
mode. You’ll see the movie playing on the TV screen and 
hear the audio track. 



Chapter 3: Creating and Previewing a Sample Project 

 52

6. Double-click the movie in the Viewport to display the 
Panel Properties dialog box. 

 

7. Deselect the Loop checkbox and click OK. This ensures 
that the movie sound plays only once, then stops. 
Otherwise, the sound would play continuously while 
you’re working.  

8. From the File menu, choose Save to save your work. 

3D MODE 

In 3D mode, elements have the appearance of depth and you 
can move around them when you pan your vistas in the Viewer. 
In this section, you’ll add 3D image objects (IMOBs) of tourists 
to the Beach vista. 

To add elements in 3D mode: 

1. Bring the Beach vista to the front in the Viewport by 
clicking its icon in the Project Manager. 

2. Click the 3D button in the Vista toolbar to switch the 
mode. 
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3. In the Asset Browser, click the Objects tab and drag the 
BeachGoer1 icon into the Viewport. When you release 
the mouse button, the man IMOB appears. 

• To set the size and proximity of the IMOB, click 
the IMOB and drag the pointer vertically. 

• To set the horizontal position of the IMOB in the 
vista, click the IMOB and drag the pointer 
horizontally. 

• To position the IMOB vertically in the vista 
without changing its size, press ALT while 
dragging the pointer across the IMOB vertically. 

• To rotate the IMOB without changing its size, 
press ALT while dragging the pointer across the 
IMOB horizontally. 

4. Drag the BeachGoer2 icon from the Asset Browser into 
the Viewport. The woman IMOB appears. 

5. Repeat the sizing and positioning procedures in Step 3 
for the woman IMOB. 

6. From the File menu, choose Save to save your work. 

 

OVERLAY MODE 

In Overlay mode, elements appear on top of the vista on the 
viewer screen space. In this lesson, you’ll add an IMOB of a 
Kalimba instrument, a Kalimba music sound, and a starfish 
image to the Market vista. 
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To add elements in Overlay mode: 

1. Bring the Market vista to the front in the Viewport by 
clicking its icon in the Project Manager. 

2. Click the Overlay button in the Vista toolbar to switch 
the mode. 

3. In the Asset Browser, click the Objects tab and drag the 
Kalimba icon into the Viewport.  

4. Double-click Kalimba. The Overlay Properties dialog box 
appears. 

 

• In the Scale field, type 50 to scale the Kalimba 
50%. 

• In the Group field, type 1 to assign the Kalimba 
to group 1. 
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• In the Layer field, type 1 to assign the Kalimba to 
layer 1. 

• Click OK to finish. 

5. Click the Group 2 button at the top of the vista window. 
You won’t see the Kalimba, since it is in Group 1. 

6. In the Asset Browser, click the Images tab and drag the 
starfish icon into the Viewport. The starfish image 
appears aligned to the upper left corner. 

7. Double-click the starfish icon in the Viewport. The 
Overlay Properties dialog box appears. 

• In the Chroma Key field, select Black. 

• The Group field shows that you’ve added the starfish 
into Group 2. 

• In the Layer field, type 2 to assign the starfish to 
layer 2. 

• Click OK. The starfish appears without the black 
background in the upper left corner of the Market 
vista. 

8. Click the All button at the top of the vista window to 
show all Groups and see both the Kalimba and the 
starfish. 

9. Click the starfish and drag it across the Kalimba to see 
how the layers work. The starfish should move behind 
the Kalimba as you drag it, since the Kalimba is in the 
first layer. 
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10. In the Asset Browser, click the Sounds tab and drag the 
Kalimba icon into the Viewport. You’ll hear the sound 
playing in the background, but you won’t see the sound 
in the Viewport, because you can’t position a sound in 
the vista space in Overlay mode. 

11. In the Project Manager, right-click the Kalimba sound 
icon and choose Properties from the shortcut menu. The 
Sound Properties dialog box appears. 

 

12. Deselect the Initially On checkbox, then deselect Loop. 
This sets the sound to off when you first view the vista 
and to play once when you turn it on. 

13. Click OK. The sound should stop playing. 

14. From the File menu, choose Save to save your work. 

In the next lesson, you’ll assign an action to the starfish image 
so that when you click it, the Kalimba sound will play. 
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LESSON 4: ASSIGNING ACTIONS TO ELEMENTS 

The actions you can assign to elements in Reality Studio are: 
Show, Hide, Toggle Show, Play, Loop, and Stop. In addition, 
you can specify a target for the action, so when you click one 
element, it triggers an action for another element. In this 
lesson, you’ll assign the Play action to the starfish, which will 
act as an on/off button to play the Kalimba music. 

To assign an action to an element: 

1. In the Viewport, double-click the starfish. The Overlay 
Properties dialog box appears. 
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2. Click the Action button. The Hotspot Properties dialog 
box appears. 

 

3. Select Action. 

• From the Type drop-down list, choose Play. 

• From the Target drop-down list, choose Kalimba. 

• In the Delay field, enter in a value for the amount of 
delay you want for the action. 

4. Click Insert to assign the action to the hotspot. You can 
enter more than action for each hotspot. Follow step #3 
until you have added all the desired actions. 

5. Click OK to close the Hotspot Properties dialog box, 
then, click OK to close the Overlay Properties dialog box. 

6. From the File menu, choose Save to save your work. 

The last lesson describes how to preview your project in the 
Plug-in Viewer. You’ll navigate the hotspots to view each vista, 
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rotate the IMOBs of the people on the beach, rotate the IMOB 
of the Kalimba in the market, and play the Kalimba sound by 
clicking on the starfish. 

LESSON 5: PREVIEWING YOUR PROJECT 

Now comes the fun part where you get to see your links and 
elements in action. You can do a quick preview to see your 
project in the internal Viewer, or you can do a browser preview 
to display your project in an HTML page that is running the 
Plug-in Viewer. 

When you preview, Reality Studio creates a Temporary Files 
folder in the same directory as your Reality Studio application 
with all of the files necessary for the Viewer to display your 
world. When you finish previewing, Reality Studio will delete 
the temporary files. 

Note: When you preview, you’ll see the iseemedia logo in the 
lower left corner of your vistas in the viewer window. When you 
click this logo, the toolbar for the Viewer appears. Pass your 
pointer over each toolbar button for a few seconds to see a tool 
tip that describes the function of each one. 

To preview your project: 

1. Choose Quick Preview or Browser Preview as follows: 

• To preview your project in the internal Viewer, 
choose Preview > Quick from the File menu or 
click the toolbar icon. Your project preview 
appears in Reality Studio in an internal version of 
the Viewer.  
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• To launch your Web browser and preview your 
project in an HTML page that is running the Plug-
in Viewer, choose Preview > Browser from the 
File menu or click the toolbar icon.  

2. Click the Private Suite vista and pan to the right to view 
the movie playing on the TV screen. 

3. Press the spacebar as you pan the vista to see the 
hotspot links, then click the hotspot, which appears as a 
red bull’s eye. The Beach vista appears in the viewer, 
replacing the Private Suite. 

4. Click the vista and pan until you see your IMOBs of the 
people on the beach, then click each one and drag to the 
right to rotate and view them on all sides. 

5. Press the spacebar as you pan the vista to see the 
hotspot links, then click the hotspot. The Market vista 
appears. You’ll immediately see the Kalimba and the 
starfish, since these are Overlay elements that appear 
on top of the vista in the screen space. 

6. Click the Kalimba IMOB and rotate to view it on all sides. 

7. Click the starfish to hear the sound of the Kalimba 
playing. 

8. When you’re done previewing, close the internal viewer 
window or the HTML page preview. 

Congratulations for taking the time to complete these 
introductory lessons, which provided a very small snapshot of 
the multitude of effects you can create using Reality Studio. 
The remaining chapters detail the procedures for working with 
each type of element in the view modes, linking vistas and 
URLs, and publishing your projects on the Web. 
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Chapter 4: Working with Elements 

The elements you create in your projects add depth and 
richness to your site visitors’ interactive experience. This 
chapter provides a breakdown of which assets you can add in 
each view mode, the elements they create, and how to edit 
those elements to achieve many sophisticated effects. 

This chapter includes how to: 

• Add and display vistas 

• Use Flat, 3D, and Overlay modes to add elements 

• Use groups and layers to achieve effects for Overlay 
elements 

• Edit vista and element properties 

• Assign actions to elements 

• Edit the media files of vistas and elements 

Note: If you haven’t already done so, take a few minutes to 
view the Reality Studio online tutorial for excellent ideas and 
tips about creative uses for elements in your projects. The 
online tutorial is on your CD-ROM or can be downloaded from 
the iseemedia website. Chapter 3, “Creating and Previewing a 
Sample Project,” also contains some hands-on examples of 
adding elements in each view mode. 

WORKING WITH VISTAS 

Vistas set the panoramic backgrounds for the scenes in your 
projects. Each time you add a vista, a new folder appears in the 
Project Manager and the vista opens in the Viewport. Each vista 
folder contains a Flat, 3D, and Overlay folder for the links and 
elements you add in each view mode. 
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Note: For more technical information about vistas, see “Image 
Worlds nodes” on page 124. 

ADDING A VISTA TO YOUR PROJECT 

When you add a vista, the view mode automatically sets to Flat 
and a new vista folder appears in the Project Manager. 

To add a vista: 

• Drag a vista (IVR file) from the Asset Browser or a local 
directory into the Project Manager. The vista opens in 
the Viewport and a new vista folder appears in the 
Project Manager with a Flat, 3D, and Overlay folder 
beneath it. 

• To navigate the vista, click on the vista in the Viewport 
and drag the pointer horizontally and vertically.  

• To resize the vista window, click the Maximize button in 
the upper right corner of the window.  

• To zoom in and out of the vista, from the View menu, 
choose Zoom In or Zoom Out or use the toolbar icons. 

DISPLAYING A VISTA IN THE VIEWPORT 

When you add a vista to your project it appears in an open 
window in the Viewport. When you open an RSD project file 
that has multiple vistas, the project folder appears in the 
Project Manager, but you have to open each vista individually. 

To display a vista in the Viewport: 

1. In the Project Manager, click the + sign next to the vista 
folder to expand it, then double-click the vista element. 
The vista opens in the Viewport and appears in front of 
the other open vistas. To switch between open vistas in 
the Viewport, press CTRL + Tab. 



Chapter 4: Working with Elements 

 63

2. To arrange the vista windows in the Viewport, from the 
Window menu, choose: 

• Cascade to show all of the vista windows stacked so 
you can see a portion of each one 

• Tile to show all of the vista windows as separate tiles 
within the Viewport 

• Arrange Icons to view all of the title bars for 
minimized vistas 

• Close All to close all of the open vista windows in the 
Viewport 

The next sections describe the elements you can add in Flat, 
3D, and Overlay mode and how to add, position, and size them. 

 

ADDING ELEMENTS IN FLAT, 3D, AND OVERLAY MODE 

The behavior and characteristics of elements vary between Flat, 
3D, and Overlay mode. For example, a panel in Flat mode has a 
position in the panoramic space, while a panel in Overlay mode 
only has a position on top of the vista in the screen space. In 
Flat mode, you can warp the contours of the panel to conform 
to the shape of the panorama, while in Overlay mode, you can 
only have a rectangular panel on the screen space. 
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The following table shows an overview of the elements you can 
add, position, and size in each view mode. 

Element Flat mode 3D mode Overlay 
mode 

Frame N/A  N/A Add, position, 
and size. 

Geometry N/A Add, position, and 
size. 

N/A 

Image 
Objects 
(IMOBs) 

N/A Add, position, and 
size. 

Add, position, 
and size. 

Panels*  
(Images & 
Movies)  

Add, 
position, and 
size. 
*Shared with 
3D mode. 

Add, position, and 
size. 
*Shared with Flat 
mode. 

Add, position, 
and size. 
*Shared with 
any other 
mode. 

Sounds N/A Add point-source 
sounds; the 
volume varies 
relative to your 
position in the 
vista. 

Add ambient-
source sounds; 
the volume 
remains 
constant 
regardless of 
your position 
in the vista. 

 

Note: Vistas automatically open in Flat mode, but you can drag 
a vista into the Project Manager regardless of which view mode 
is active. 

ADDING ELEMENTS IN FLAT MODE 

The elements you add in Flat mode are in the panoramic space, 
which means that they appear as if they are fixed to the 
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surface of the panorama. For example, you can position a 
picture on a wall in a vista and when you view your project in 
the Web page, the picture on the wall moves in and out of view 
as you navigate around the vista. You can size, position, and 
warp panels to conform to the shape of the vista, which can be 
a sphere, cylinder, or cube. 

The following table shows the asset you can add in Flat mode 
and the type of element it creates in the project: 

Asset Element 

Panel 
(Images & Movies) 

Rectangular object, such as: 

• Picture on a wall 

• Movie playing on a TV screen 

ADDING ELEMENTS IN 3D MODE 

In 3D mode, you add elements into the 3D space. In this mode, 
elements appear to have depth and you can move around them 
when you pan the vista. For example, if you place an image 
panel in 3D mode, when you pan the vista, it appears as if you 
are able to move around the panel and view it from various 
perspectives. 

In 3D mode, you have three positioning coordinates: 

• x (horizontal/width) 

• y (vertical/length) 

• z (depth) 

For example, a square-shaped panel in Flat mode, would have 
horizontal (x) and vertical (y) coordinates for the height and 
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width. In 3D mode, the square becomes a cube, because it has 
the depth (z) coordinate. 

The following table shows each asset you can add in 3D mode 
and the type of element each one creates in the project: 

Asset Element 

Geometry 3D object represented be geometric primitives 
and texture maps. 

Image Object 
(IMOB) 

A collection of photographic images that 
represent an object in 3D space, such as a 
bottle or a person you can rotate and view on 
all sides. 

Panel 
(Images & Movies) 

Rectangular object, such as: 

• Picture on a wall 

• Movie playing on a TV screen 

Panels appear to be “floating” in 3D mode. 

Note: You can see, move, and size the panels 
you added in Flat mode. 

Sounds Point-source sound; the volume and 
directional quality varies according to where 
you pan in the vista. 

 

ADDING ELEMENTS IN OVERLAY MODE 

The elements you add in Overlay mode appear on top of the 
vista on the screen space. No matter where you pan in the 
vista, the element stays visible on the screen. For example, you 
could place your company logo over a vista so it shows on the 
screen all the time. 
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The following table shows the assets you can add in Overlay 
mode and the elements they create: 

Asset Element 

Frame A rectangular image to be used as a border 
around the Viewer. 

Image Object 
(IMOB) 

A collection of photographic images that 
represent an object in 3D space, such as a 
bottle or a person you can rotate and view on 
all sides; in Overlay mode, the IMOB always 
remains visible no matter where you navigate 
in the vista. This is a Screen IMOB, rather 
than the IMOB you add in 3D mode, which is 
a World IMOB. 

Panel 
(Images & Movies) 

Rectangular shape, such as: 

• Button or logo that stays on the 
screen no matter where you navigate 
in the vista. 

Sounds Ambient-source sound; the volume and 
directional quality remains the same 
regardless of where you pan in the vista. 

 

GROUPS AND LAYERS 

In Overlay mode, you can assign elements to groups and layers 
to achieve complex effects, especially when combined with the 
actions you can assign to them. For example, you could click a 
button to show a group of shirts or blouses for sale, then click 
another button to hide that group of garments or show a 
different group of garments. 
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To work through a hands-on example of assigning groups and 
layers to Overlay elements, see Chapter 3, “Lesson 3: Adding 
elements in Flat, 3D, and Overlay mode” on page 45. 

Note: This section describes the basic concepts about groups 
and layers and how to assign them to elements. For information 
about assigning actions, see “Assigning actions to elements and 
Overlay groups” on page 89. 

ADDING AN OVERLAY ELEMENT TO A GROUP 

Each time you add an element in Overlay mode, it becomes 
part of the current Overlay group. You can set the current 
group by clicking one of the group number buttons above the 
vista window in Overlay mode. 

You can target Overlay groups with actions to hide, show, and 
play multiple elements and sounds. For more information, see 
“Assigning actions to elements and Overlay groups” on page 
89. 

To add an element to a group: 

1. From the View menu, choose Vista > Overlay or click the 
toolbar icon to set the mode. 

2. Click one of the numbered buttons above the vista to 
add elements to that group. 

3. Place the Overlay elements you want into that group 
using the procedure for the type of element you’re 
adding. 

4. To continue assigning elements to different groups, click 
a numbered button for each element or group of 
elements you want to add. 

5. To view all of the groups at once, click the All button in 
the toolbar above the vista window in Overlay mode. 
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ADDING AN OVERLAY ELEMENT TO A LAYER 

Layering lets you assign a placement for elements so they 
appear in front of or behind other elements. In Reality Studio, 
you can use layers 1 to 1,000, with each successive layer 
appearing behind the previous layer. This lets you control the 
ordering of overlapped images. For example, you could add a 
shirt image panel to layer 5, an IMOB of a person to layer 8, 
and a starfish image panel to layer 3. The starfish would appear 
in front of the shirt, which would appear in front of the person. 

To add an Overlay element to a layer: 

1. From the View menu, choose Vista > Overlay. 

2. Double-click the element to set its layer. The properties 
dialog box appears for that type of element. 

3. In the Layer field, type a number from 1 to 1,000, 
depending on the number of layers you want to create. 

4. Click OK to finish. 

WORKING WITH FRAMES 

Frames provide a border around the vista in the Viewer. What 
you actually do is add the frame image, then scale it to the 
same size as the vista and use the Chroma Key setting to key 
out the inside color of the frame so the vista and elements 
show through. 

To add a frame in Overlay mode: 

1. From the View menu, choose Vista > Overlay or click the 
toolbar icon to set the mode. The group buttons appear 
above the vista in Overlay mode. The default is to show 
all groups. 
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2. If you wish, click a numbered group button to assign the 
frame to a specific group. Otherwise, it will appear in 
group 0. 

3. In the Asset Browser, click the Frames tab to show the 
frame assets or open a local directory that contains a 
frame file. 

4. Drag the frame into the open vista in the Viewport. The 
frame appears in the vista and its icon appears in the 
Overlay folder within the vista folder in the Project 
Manager. 

• To scale the frame in proportion, click inside the 
frame and press the S key while dragging. 

• To position the frame, click inside the frame and 
drag horizontally or vertically. 

• To key out the background color in the frame, 
double-click the frame in the Viewport to show 
the Overlay Properties dialog box. In the Chroma 
Key field, select the color to key out, then click 
OK. To edit other frame properties, see 
“Geometry and Image objects (IMOBs) in 3D 
mode” on page 82. 

 

WORKING WITH GEOMETRY ELEMENTS 

You can create geometry objects in 3D rendering programs or 
in Virtual Reality Modeling Language (VRML) files that contain a 
Shape node. Simple examples of geometry elements are balls 
and boxes, or tables and chairs. You can only add geometry 
elements in 3D mode. 
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The iseemedia assets installed with Reality Studio include some 
geometry objects for you to use in your projects. 

To add a geometry element in 3D mode: 

1. 1. From the View menu, choose Vista > 3D to set the 
mode. 

2. In the Asset Browser, click the Geometry tab to show 
the geometry assets or open a local directory that 
contains a geometry file. 

Note: You can also add custom asset collections to 
Reality Studio. See “Creating custom asset collections” 
on page 36. 

3. Drag the geometry asset or file into the open vista 
window in the Viewport. The geometry element appears 
in the vista and in the 3D folder within the vista folder in 
the Project Manager. 

• To move the geometry element along the 
horizon, click inside the geometry element and 
drag the pointer horizontally. 

• To move the geometry element closer or farther 
away in proximity, click inside the geometry 
element and drag the pointer vertically. The size 
of the element appears to increase and decrease 
according to where you move it in the 3D space. 

• To position the geometry element vertically, click 
inside the geometry element and press ALT while 
dragging the pointer vertically. 

• To rotate the geometry element around its 
vertical axis, press ALT while dragging the 
pointer horizontally across the element. 
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WORKING WITH IMAGE OBJECTS (IMOBS) 

Image objects (IMOBs) enhance the interactive experience of 
your projects, because you can rotate them to view details on 
all sides. For example, your site visitors can pull a product, 
such as a camera, off of a shelf and see more of its features 
than a 2D image can deliver. You can add IMOBs in 3D and 
Overlay mode. 

Photovista 3D Objects, which is included in your Reality Studio 
CD-ROM, easily creates IMOBs from a series of photos of a real-
world object. For information, see the online Help for Photovista 
3D Objects. 

Note: Image objects are one of the iseemedia extensions to 
VRML 2.0. For more information about this node type, see 
Chapter 7, “Behind the Scenes”, on page 123. 

ADDING AN IMOB IN 3D MODE 

In 3D mode, the IMOBs you add move in the view as you pan 
your vista. These can be referred to as World IMOBs, which 
means that they have a position in the 3D space. 

To add an IMOB in 3D mode: 

1. From the View menu, choose Vista > 3D or click the 
toolbar icon to set the mode. 

2. In the Asset Browser, click the Objects tab or open a 
local directory that has an IVR file with an IMOB in it, 
such as a file created using Photovista 3D Objects. 

3. Drag the IMOB asset or IVR file into the open vista 
window in the Viewport. The IMOB appears in the vista 
and the 3D folder within the vista folder in the Project 
Manager. A bounding box appears around the IMOB. 
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• To position the IMOB horizontally (X axis) or 
move it closer or farther away in proximity (Z 
axis), click inside the IMOB and drag. The size of 
the IMOB appears to increase and decrease 
according to where you move it in the 3D space. 

• To position the IMOB vertically (Y axis), press 
ALT while dragging the pointer up and down. 

• To rotate the IMOB, press ALT while dragging the 
pointer horizontally around the IMOB. 

• To scale the IMOB, press the s key while 
dragging the pointer diagonally across the 
element. 

ADDING AN IMOB IN OVERLAY MODE 

In Overlay mode, image objects are fixed onto the screen space 
and won’t move out of view when you pan your vista as they do 
in 3D mode. For this reason, they can be referred to as Screen 
IMOBs. You can scale the IMOBs in Overlay mode and rotate 
them to view the details from all sides. 

To add an IMOB in Overlay mode: 

1. From the View menu, choose Vista > Overlay or click the 
toolbar icon to set the mode. The group buttons appear 
above the vista in Overlay mode. The default is to show 
all groups. 

2. If you wish, click a numbered group button to assign the 
IMOB to a specific group. Otherwise, it will appear in 
group 0. 

3. In the Asset Browser, click the Objects tab to show the 
IMOB assets or open a local directory that has an IVR 
file that contains an IMOB. 
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4. Drag the IMOB asset or IVR file into the open vista 
window in the Viewport. The IMOB appears in the vista 
and the Overlay folder in the Project Manager. 

• To scale the IMOB, click inside the IMOB and 
press the S key while dragging. 

• To position the IMOB, click inside the IMOB and 
drag horizontally or vertically. 

WORKING WITH PANELS 

Panels are rectangular elements, such as pictures on a wall or 
movies playing on a TV screen. You can add panels in Flat, 3D, 
and Overlay mode and the panel characteristics and 
appearance vary according to the mode. Panels appear as 
trackers in Flat mode, but you can see the image content when 
you switch to 3D mode. 

ADDING A PANEL IN FLAT MODE 

When you add a panel in Flat mode, it appears as a tracker in 
the Viewport with four corner handles for sizing and positioning. 
You can only see the image or movie content when you preview 
or switch to 3D mode. 

Note: Panels in Flat mode are shared with 3D mode; you can 
size and position the panel in both modes. It is useful to switch 
between the two modes to see how the panel behaves in each 
one, and to fine-tune its position in the vista. 

To add a panel in Flat mode: 

1. From the View menu, choose Vista > Flat or click the 
toolbar icon to set the mode. 

2. In the Asset Browser, click the tab for the type of panel 
you want to add (image or movie) or open a local 
directory that contains the media file you want to use. 



Chapter 4: Working with Elements 

 75

• To view a thumbnail image of the panel in the Asset 
Browser, click the asset icon. The thumbnail appears 
in the right pane of the Asset Browser. 

Note: You can click the Add Assets button in the Asset 
toolbar to create a new asset collection from a local 
directory. See “Creating custom asset collections” on page 
36. 

3. Drag the image or movie icon from the Asset Browser or 
your desktop into the open vista window in the 
Viewport. The panel appears in the vista and in the Flat 
folder in the Project Manager. In Flat mode, you see the 
panel tracker with a handle in each corner. To view the 
media file, switch to 3D mode. 

• To position the panel, click inside the element 
and drag.  

• To change the shape of the panel, place the 
pointer over one of the corner handles until the 
pointer changes to an arrow, then click and drag. 

• To scale the panel size while maintaining its 
proportions, press the S key while dragging. 

• To warp the panel so its contours conform to the 
shape of the panorama, press the ALT key while 
dragging the panel in the vista. You’ll see the 
shape of the panel change as you move it in the 
panoramic space. 

ADDING A PANEL IN 3D MODE 

Panels are shared between Flat and 3D mode. You can see the 
image in 3D mode, but when you switch to Flat mode, you only 
see the tracker. It is useful to switch back and forth between 
the two modes to see how a panel behaves in each one, and to 
fine-tune its position in the vista. 



Chapter 4: Working with Elements 

 76

To add a panel in 3D mode: 

1. From the View menu, choose Vista > 3D or click the 
toolbar icon to set the mode. 

2. In the Asset Browser, click the tab for the type of panel 
you want to add (image or movie) or open a local 
directory that contains the media file you want to use. 

3. Drag the panel into the open vista window in the 
Viewport. The panel appears in the vista and in the 3D 
folder in the Project Manager. 

• To change the shape of the panel, click inside one of 
the corners and drag. 

• To scale the panel proportionately, click inside the 
panel and press the S key while dragging. 

• To position the panel, click the center of the panel 
and drag. To constrain the panel within its own 
plane, press the ALT key while dragging. 

• To move the panel closer or farther away, press the 
N key while dragging. 

ADDING A PANEL IN OVERLAY MODE 

When you add a panel in Overlay mode, the panel appears on 
the viewer screen no matter where you navigate in the vista. 
This is useful for adding such things as logos or navigation 
buttons. 

Note: For information about using groups and layers, see 
“Groups and layers” on page 67. 
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To add a panel in Overlay mode: 

1. From the View menu, choose Vista > Overlay or click the 
toolbar icon to set the mode. The Group buttons appear 
above the vista in Overlay mode. The default is to show 
all groups. 

2. If you wish, click a numbered group button to assign the 
panel to a specific group. 

3. Drag an image or movie from the Asset Browser or a 
local directory into the open vista window in the 
Viewport. The panel appears in the vista and in the 
Overlay folder in the Project Manager. 

• To position the panel, click inside the panel and drag 
to position. 

• To scale the panel, click inside the panel and press 
the S key while dragging. 

WORKING WITH SOUNDS 

Sounds add a rich, atmospheric touch to your projects and 
provide such things as narratives for travel tours or selling 
products, and background music. You can add sounds in 3D 
mode, where the volume and position of the sounds change as 
you pan your vistas, or in Overlay mode, where the sounds play 
at a constant volume and position. 

ADDING A SOUND IN 3D MODE 

When you add a sound in 3D mode, it has a position in the 3D 
space, which means that the volume varies as you pan around 
the vista and the sound moves between the left and right 
speaker. 
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To add a sound in 3D mode: 

1. From the View menu, choose Vista > 3D or click the 
toolbar icon to set the mode. 

2. In the Asset Browser, click the Sounds tab to show the 
sound assets or open a local directory that contains a 
sound file on your hard drive. To add an asset collection 
from a local directory, see “Creating custom asset 
collections” on page 36. 

3. Drag the sound file into the open vista in the Viewport. 
The sound icon, which resembles a speaker, appears. 

4. Adjust the volume of the sound by clicking on the icon 
and dragging the pointer up and down. The volume 
increases as the sound icon appears larger and 
decreases as the sound icon appears smaller. 

5. Set the sound position in the vista by clicking the sound 
icon and dragging horizontally. You’ll hear the sound 
move between your left and right speakers as you drag. 

6. To rotate the sound to change the volume and 
projection quality, press the ALT key while dragging the 
pointer horizontally. 

ADDING A SOUND IN OVERLAY MODE 

A sound in Overlay mode plays in the background at a constant 
volume level. You won’t see a sound icon in the Viewport, since 
the sound doesn’t have a specific position anywhere on the 
vista. 

To add a sound in Overlay mode: 

1. From the View menu, choose Vista > Overlay or click the 
toolbar icon to set the mode. The Group buttons appear 
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above the vista in Overlay mode. The default is to show 
all groups. 

2. If you wish, click a numbered button to assign the sound 
to a specific group. 

3. Drag a sound asset from the Asset Browser or a local 
directory into the Viewport. The sound icon appears in 
the Project Manager in the Overlay folder within the 
vista folder. You’ll hear it playing, but you won’t see a 
sound icon on the vista in the Viewport. 

EDITING ELEMENT PROPERTIES 

After you add vistas and elements to your project, each one 
has a set of properties you can customize to set or adjust such 
things as field of view, scaling, alignment, chroma key masking, 
offset, and so on. After you edit the vista or element properties, 
the changes appear in the Viewport. You can continue to fine-
tune the element properties as you work on your project. 

Note: For details about editing the underlying media files, see 
“Editing the media files for vistas and elements” on page 92. 

VISTAS 

The shape of a vista and the field of view settings determine 
the degree of the horizontal and vertical view. The panoramic 
images in vistas are warped in a sphere, cube, or cylinder 
shape. You can reset the field of view for your vista by editing 
the vista properties, but the shape is determined by the source 
file. 

To edit the vista properties: 

1. Select the vista in the Project Manager and from the Edit 
menu, choose Properties. You can also right-click the 
vista in the Project Manager and choose Properties from 
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the shortcut menu. The Vista Properties dialog box 
appears. 

 

2. To rename the vista, type a name in the Element Name 
field. 

Note: The Projection Type field shows the current 
projection type of the panorama; changing this setting 
will update a corresponding field in the exported IVR file, 
but will not modify the vista's image media. To change 
the vista's projection setting and media, open the vista 
(IVR file) in Photovista and save the panorama using a 
different projection type. Also, in order to change the 
projection type without distorting the vista, the vista 
must have an aspect ratio of 1x6. 

3. To set the horizontal or vertical field of view, type the 
number of degrees. 

4. To change the source panorama associated with the 
vista, click Browse and navigate to the panoramic image 
file you want. The Source File field shows the full path to 
the image file associated with the vista. 
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5. If you’re using a Flashpix vista and creating content for 
the Web, in the Remote Path field, type the URL for 
Flashpix images on your Zoom Image Server. If you’re 
using any other type of image file or creating content for 
a CD-ROM, you don’t need to specify a remote path. See 
“Specifying remote path names” on page 118. 

6. When you’re finished editing the vista properties, click 
OK. 

PANELS IN FLAT AND 3D MODE 

The panels you add in Flat and 3D mode share a set of 
properties, even though their position and behavior in the vista 
space is different. Anything related to scaling and positioning 
must be done manually. 

To edit panel properties in Flat and 3D mode: 

1. Double-click the panel in the Viewport or right-click the 
panel icon in the Project Manager and choose Properties 
from the shortcut menu. The Panel Properties dialog box 
appears. 

 

2. To rename the panel, type a name in the Element Name 
field. 
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3. To choose a different source file for the panel, click 
Browse and navigate to the file you want in a local 
directory or a CD-ROM. 

4. If you’re using Flashpix image panels and creating 
content for the Web, in the Remote Path field, type the 
URL for Flashpix images on your Zoom Image Server. If 
you’re using any other type of image file or creating 
content for a CD-ROM, you don’t need to specify a 
remote path. See “Specifying remote path names” on 
page 118. 

5. To initially hide the panel, deselect the Initially Visible 
checkbox. 

6. If you’re working with a movie panel or an animated 
GIF, deselect Loop to have the panel stop playing after 
the first cycle.  

7. Select one of the Chroma Key colors to eliminate a 
specific color from the panel so the element behind the 
panel shows through that area. 

8. To assign an action to the panel, see “Assigning actions 
to elements and Overlay groups” on page 89. 

9. When you’re done setting properties, click OK. 

GEOMETRY AND IMAGE OBJECTS (IMOBS) IN 3D MODE 

Geometry and 3D IMOBs have a set of properties related to 
their position in the 3D space, such as direction, distance, 
rotation, and height. To edit Overlay IMOBs, see the next 
section, “Panels, frames, and Image objects (IMOBs) in Overlay 
mode” on page 84. 
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To edit geometry or IMOB properties in 3D mode: 

1. Double-click the element in the Viewport or right-click 
the element in the Project Manager and choose 
Properties from the shortcut menu. The Geometry 
Properties dialog box appears. 

 

2. To rename the element, type a name in the Element 
Name field. 

3. To choose a different source file for the element, click 
Browse and navigate to the file you want in a local 
directory or a CD-ROM. 

4. If you’re using a Flashpix image object (IMOB) and 
creating content for the Web, in the Remote Path field, 
type the URL for Flashpix images on your Zoom Image 
Server. If you’re using any other type of image file or 
creating content for a CD-ROM, you don’t need to 
specify a remote path. See “Specifying remote path 
names” on page 118. 

5. To initially hide the element, deselect the Initially Visible 
checkbox. 

6. To change the scale of the element, type a number in 
the Scale field. 
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7. The direction, distance, rotation, and height settings for 
the element represent your manual positioning, rotation, 
and sizing of the element. You can fine-tune these by 
adjusting the numbers in each field. 

8. To assign an action to the element, see “Assigning 
actions to elements and Overlay groups” on page 89. 

Distance—element’s horizontal distance from the center 
of the vista, in Virtual Reality Modeling Language (VRML) 
units (meters). 

Direction—element’s horizontal position in relation to the 
starting point of the vista; in degrees about the vertical 
axis of the vista. 

Rotation—element’s orientation about its own vertical 
axis, in degrees. 

Height—element’s vertical position in relation to the 
equatorial plane (ground) of the vista, in VRML units 
(meters). 

9. When you’re done setting properties, click OK. 

 

PANELS, FRAMES, AND IMAGE OBJECTS (IMOBS) IN OVERLAY 
MODE 

Overlay elements have a specific set of properties related to 
their position on the screen space, such as the X, Y offset, as 
well as the option to assign the element to a group or layer. 
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To edit element properties in Overlay mode: 

1. Double-click the element in the Viewport or right-click 
the element in the Project Manager and choose 
Properties from the shortcut menu. The Overlay 
Properties dialog box appears. 

 

2. To rename the element, type a name in the Element 
Name field. 

3. To choose a different source file for the element, click 
Browse and navigate to the file you want in a local 
directory or a CD-ROM. 

4. If you’re using a Flashpix image panel or image object 
(IMOB) and creating content for the Web, in the Remote 
Path field, type the URL for Flashpix images on your 
Zoom Image Server. If you’re using any other type of 
image file or creating content for a CD-ROM, you don’t 
need to specify a remote path. See “Specifying remote 
path names” on page 118. 
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5. To initially hide the element, deselect the Initially Visible 
checkbox. 

6. To have the element disappear when you click it, select 
the Click-Away checkbox. 

7. To change the scale of the element, type a number in 
the Scale field. 

8. To assign the element to a different group or layer, type 
a number in the Group and Layer fields. 

9. To reposition the element, type a number in the X and Y 
Offset fields. The numbers that appear show your 
current settings. 
For Overlay elements, the X, Y offset zero point is the 
upper left corner of the element. When you type a 
positive number in the X Offset field, the element moves 
to the right from the zero point. When you type a 
positive number in the Y Offset field, the element moves 
downward from the zero point. 

10. Select one of the Chroma Key colors to eliminate a 
specific color from the element. This is particularly 
useful for editing out the background color in an 
element. 

11. Select an alignment option, if desired. 

12. To assign an action to the element, see “Assigning 
actions to elements and Overlay groups” on page 89. 

13. When you’re done setting properties, click OK. 
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Note: Since frames provide a border around the Viewer, you 
might also want to set the size of the viewer window when 
editing frames. To do so, in the Project Manager, right-click the 
project icon and choose Properties from the shortcut menu to 
show the Project Properties dialog box. Set the width and 
height dimensions and click OK. For more details, see “Setting 
Project Properties” on page 109. 

SOUNDS 

Sounds have slightly different properties in 3D and Overlay 
mode. In 3D mode a sound has a position in the 3D space, 
while in Overlay mode the sound is on top of the vista in the 
screen space and has no specific position in the vista. 

To edit sound properties in 3D and Overlay mode: 

1. Right-click the sound icon in the Project Manager and 
choose Properties from the shortcut menu. (For sounds 
in 3D mode you can double-click the sound icon in the 
Viewport, as well.) The Sound Properties dialog box 
appears. 

 

2. To rename the sound, type a name in the Element Name 
field. 
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3. To choose a different source file for the sound, click 
Browse and navigate to the file you want in a local 
directory or a CD-ROM. 

4. In the Remote Path field, you can type the path to a 
remote sound file. However, this field is mainly for 
specifying the URL for Flashpix images, which will be 
uploaded to the Zoom Image Server if you’re creating 
content for the Web. See “Specifying remote path 
names” on page 118. 

5. To stop the sound from playing initially, deselect the 
Initially On checkbox. This step is important if you’re 
mixing sound files (such as WAV, AVI, and MOV) in the 
same project and want to play sounds only when 
triggered by an action, such as clicking a button. 

6. To have the sound stop playing after the first cycle, 
deselect the Loop checkbox. 

7. For sounds in 3D mode, the distance, rotation, orbit, and 
height settings represent your manual positioning, 
rotating, and sizing of the sound. Adjust these settings 
as you wish. For sounds in Overlay mode, these fields 
will appear dimmed, because the Overlay sound is 
positioned only on the screen space. 

Distance—sound’s horizontal distance from the center of 
the vista, in Virtual Reality Modeling Language (VRML) 
units (meters). 

Direction—sound’s horizontal position in relation to the 
starting point of the vista; in degrees about the vertical 
axis of the vista. 

Rotation—sound’s orientation about its own vertical axis, 
in degrees. 
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Height—sound’s vertical position in relation to the 
equatorial plane (ground) of the vista, in VRML units 
(meters). 

8. When you’re done setting properties, click OK. 

 

ASSIGNING ACTIONS TO ELEMENTS AND OVERLAY GROUPS 

You can achieve sophisticated, interactive effects by assigning 
actions to elements or groups of Overlay elements. A simple 
example is clicking a button to play a movie or sound. A more 
complex example is to initially hide a whole group of Overlay 
elements, then show that group by clicking a button. 

The following table describes the actions that you can trigger 
when you click an element or group of Overlay elements: 

Action Description 

Show Shows the element or its target. 

Hide Hides the element or its target. 

Toggle Show Alternates between showing and 
hiding the element or its target. 

Play (movies, sounds, 
animated GIFs) 

Plays the elements or its target 
through one cycle. 

Loop (movies, sounds, 
animated GIFs) 

Causes the element or its target to 
play continuously 

Stop (movies, sounds, 
animated GIFs) 

Stops the play cycle for the element or 
its target. 
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Note: To work through an example of assigning actions to 
elements, see “Lesson 4: Assigning actions to elements” on 
page 57. You can see an example in the online tutorial on your 
Reality Studio CD-ROM. 

SETTING UP THE TRIGGER ELEMENT 

The element that causes the action when clicked is the trigger 
element. An example is a button that you click to turn on a 
movie or sound. 

To set up the trigger element: 

1. In the Viewport, double-click the element, or in the 
Project Manager, right-click the element and choose 
Properties from the shortcut menu. The Properties dialog 
box appears for that type of element. 

2. Click Action. The Hotspot Properties dialog box appears. 

 

3. Select Action, then choose an action from the Type 
drop-down list. For example, to toggle between showing 
and hiding an element or group, choose Toggle Show. 
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4. In the Target drop-down list, choose a target element or 
group for the action. 

5. Select a delay duration by entering in a number in the 
Delay field. 

6. Click Insert to add the action to the Action queue.  

Note: More than one action can be assigned to an 
element. Continue to select actions and click Insert to 
add the action to the Action Queue. 

7. Click OK to close the Hotspot Properties dialog box. 
When you preview your project, the pointer turns into a 
hand when you pass it over the triggering element. 

SETTING UP THE TARGET ELEMENT OR GROUP 

Sometimes you need to set up the target element or group for 
the trigger action. For example, to play a sound or movie when 
you click a button, you have to make sure the sound or movie 
is turned off when you first view the vista. 

To set up the target element or group: 

1. In the Viewport, double-click the element, or in the 
Project Manager, right-click the element and choose 
Properties from the shortcut menu. The element 
properties dialog box appears. For a group of elements, 
you need to do this for each element in the group. 

2. The default is to show or play the element. To hide or 
stop the element when you first view the vista, deselect 
the Initially Visible or Initially On checkbox. 

3. Click OK to save your setting. 
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EDITING THE MEDIA FILES FOR VISTAS AND ELEMENTS 

When you edit the media file associated with a vista or 
element, the changes appear in your project. However, the 
changes only affect the copy of the media file Reality Studio 
creates when you save your project; the changes don’t affect 
the original asset file. 

To edit the media files for vistas and elements: 

1. Select the vista or element icon in the Project Manager 
and from the Edit menu, choose Launch Editor. You can 
also right-click the vista or element in the Project 
Manager and choose Launch Editor from the shortcut 
menu. 

• If there is no application associated with the file 
type, the Program Not Found dialog box appears. 

• Click Locate and navigate to the directory for the 
editing application, then click OK to launch the 
application. 

Note: To associate an application with a file type, refer 
to your Windows print documentation or Windows online 
Help. 

2. Make the changes to the media file and save the 
changes, then exit the editing application. The changes 
appear in the corresponding vista or element in your 
project. 
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APPLYING PLUG-IN EFFECTS 

Plug-in effects can be applied to any vista or image, providing 
you have Adobe Photoshop® installed on your computer. The 
effects that are available to you are supplied by Adobe 
Photoshop and can be selected from the Plug-in drop-down 
menu. Once you select an effect, click Apply. A settings dialog 
will be displayed where you can alter parameters related to that 
effect. For more information on what each effect can do to your 
vista or image, read the Adobe Photoshop online help. 

To apply a plug-in effect: 

1. Select the vista or image you would like to apply the 
plug-in effect to. 

2. Select Apply Plug-in Effects from the Tools menu or click 
the toolbar icon to display the Plug-in Effects dialog box. 
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3. From the Plug-in drop-down menu, select the effect you 
would like to use. 

4. Click the Apply button. Depending on the effect selected, 
a dialog box will be displayed where you can adjust the 
parameters of the effect. Once OK is clicked, the 
preview window will display how the effect will be 
applied to your vista or image. If a dialog box is not 
displayed, then the effect will automatically be applied 
to your vista or image and will be reflected in the 
preview window.  

5. Click undo to remove the plug-in effect from the vista or 
image. 

6. If you are happy with the effect applied to your vista or 
image, click the Save button. Cancel will close the Plug-
in Effect dialog box without applying an effect. 
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CHAPTER 5: Linking Vistas and Elements 

Links between vistas are the foundation of your interactive 
websites, letting your site visitors “move” through rooms and 
other locations. Reality Studio makes it easy for you to link 
vistas together, and to create external links from vistas and 
elements to URLs and other HTML pages. 

This chapter describes how to: 

• Link vistas together within your project  

• Link to a new view within the same vista 

• Link vistas to external URLs and HTML pages so you can 
show descriptive text and web graphics or other 
websites 

• Link elements to vistas and URLs 

• Edit vista and element links after you create them 

CREATING VISTA LINKS 

You can create multiple links within and between vistas to 
change views. You can position the links wherever you want in 
the vistas and set exit and entry views for each one. When you 
set the exit and entry views, you can click on an area, such as 
a doorway, to go to a specific point in another vista or to a new 
view in the same vista. For example, you can enter a vista of a 
tropical beach at the sand’s edge, looking out at the ocean, 
then click a hotspot to a view farther down the beach toward 
the palm trees. 

Note: To view your links when you preview your project in the 
Viewer, press the spacebar; the links appear as red bull’s eyes. 

 



Chapter 5: Linking Vistas and Elements 

 96

This section describes how to link vistas using: 

• The drag-and-drop method 

• The Hotspot button in the Vista toolbar 

USING THE DRAG-AND-DROP METHOD 

When you drag a vista from the Project Manager onto a vista in 
the Viewport, Reality Studio creates a link between the two 
vistas. You can also drag a vista icon onto an open copy of the 
same vista in the Viewport to create a link to a new view within 
that vista. 

To create a vista link using the drag-and-drop method: 

1. In the Project Manager, click the vista to which you want 
to add a link. The vista appears in front of the other 
windows in the Viewport. 

2. From the View menu, choose Vista > Flat or click the 
toolbar icon. 

3. From the Project Manager, drag the vista icon you want 
to link onto the open vista in the Viewport. The Link 
Transition dialog box appears. 
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Note: If you don’t want to set the link transition, press CTRL 
while dragging the vista from the Project Manager into the 
Viewport. This prevents the Link Transition dialog box from 
appearing. 

• To set link transition properties, go directly to “Setting 
the link transition” on page 96. 

• To leave the settings as they are, click OK. The link 
appears on the open vista and in the Flat folder in the 
Project Manager. 

The finished link shows the name of the vista to which it is 
linked and appears in the Viewport surrounded by a tracker 
with a handle at each corner. 

• To position the link, pass the pointer over the tracker 
until the pointer changes to a crosshair, then drag the 
hotspot into position. 

• To resize the link, pass the pointer over one of the sides 
or corners of the tracker until the pointer changes to a 
double arrow, then drag to size. 

USING THE HOTSPOT BUTTON 

The Hotspot button in the Vista toolbar is another convenient 
way to add links between vistas. You must be working in Flat 
mode to use the Hotspot button. 

To link vistas using the Hotspot button: 

1. In the Project Manager, click the vista to which you want 
to create a link. The vista appears in front of the other 
windows in the Viewport.  

2. From the View menu, choose Vista > Flat or click the 
toolbar icon. 
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3. Click the Hotspot button in the Vista toolbar, then click 
the vista where you want to create the link and drag to 
size the hotspot rectangle. When you release the mouse 
button after sizing the rectangle, the Hotspot Properties 
dialog box appears. 

 

4. Click Vista Link, then choose the vista to link from the 
drop-down menu. This menu lists the vistas that are in 
your project. 

5. Click the Transition button. The Link Transition dialog 
box appears. 
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6. Choose one of the following options: 

• To set link transition properties, go directly to the 
next topic, “Setting the link transition” on page 
96. Follow the procedure to finish adding your 
hotspot link. 

• To leave the settings as they are, click OK, then 
click OK in the Hotspot Properties dialog box. 

Note: The Nothing option is only an indicator that there is no 
event associated with a particular vista or element. You can 
create a hotspot and leave Nothing selected if you want to 
temporarily not assign the hotspot to a target. 

The finished hotspot shows the name of the vista to which it is 
linked and appears in the Viewport surrounded by a tracker 
with a handle at each corner. 

• To position the hotspot, pass the pointer over the 
tracker until the pointer changes to a crosshair, then 
drag the hotspot into position. 

• To resize the hotspot, pass the pointer over one of the 
sides or corners of the tracker until the pointer changes 
to a double arrow, then drag to size. 
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SETTING THE LINK TRANSITION 

You have the option of setting an entry and exit view for each 
vista link, the field of view, and the speed and presentation of 
the link. These settings enhance the experience of changing 
views, so take some time to experiment with the effects you 
can achieve. For example, when you use a Pan and Zoom 
transition type, the vista pans, then zooms into the next vista 
or view at the duration time you set. 

To set the link transition: 

1. If the Link Transition dialog box is open, proceed to Step 
2. If the Link Transition dialog box is not open, double-
click the link in the open vista or in the Project Manager. 
The Hotspot Properties dialog box appears. 

 

2. If desired, type a new name for the link in the Element 
Name field. 

3. Click Transition. The Link Transition dialog box appears. 
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4. To set the viewpoint for the exit and entry views of the 
link, click on the Exit View or Entry View and drag the 
pointer over the vista until you see the viewpoint you 
want. The degrees in the Pitch and Yaw fields change as 
you pan. 

The pitch, yaw, and field of view settings determine the 
vista viewpoint in the Viewer. 

• Pitch—sets the vertical position or tilt 

• Yaw—sets the horizontal starting position for panning 
the vista 

• Field of View—sets the size of the view; the view 
decreases as you zoom in and increases as you zoom 
out 

5. Click the Exit or Entry view and press Shift to decrease 
the field of view (zoom in) or CTRL to increase the field 
of view (zoom out). The field of view values change 
accordingly. 

6. From the Transition Type drop-down list, select one of 
the types and enter a number of seconds for the 
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duration, if applicable. The pitch, yaw, and field of view 
settings determine the vista viewpoint in the Viewer. 

• Cut—closes the vista view you’re exiting and loads 
the vista view you’re entering. The Duration field 
appears dimmed, because the transition is 
immediate. 

• Pan and Zoom—pans the vista view you’re exiting 
and zooms gradually into the vista view you’re 
entering. In the Duration field, type the number of 
seconds for the transition. 

7. When you’re done choosing settings, click OK in the Link 
Transition dialog box, then click OK in the Hotspot 
Properties dialog box. The link appears on the open vista 
and in the Flat folder in the Project Manager; the link 
has the same name as the vista to which it links. 

• To position the link, pass the pointer over the tracker 
until the pointer changes to a crosshair, then drag 
the link into position. 

• To resize the link, pass the pointer over one of the 
sides or corners of the tracker until the pointer 
changes to a double arrow, then drag to size. 

LINKING VISTAS TO URLS 

External links let you link a vista or an element to a URL by 
replacing the current browser content, opening a new Web 
page, or targeting a specific HTML frame. For example, you 
could click a hotspot on a vista of a beach and show the home 
page of a nearby resort, or you could click a frame on an HTML 
page to display driving directions to the beach. 
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USING THE DRAG-AND-DROP METHOD 

You can create shortcuts to HTML pages and drag the shortcuts 
onto an open vista in the Viewport to create a link to that page. 
The iseemedia asset collection has a URL tab in the Asset 
Browser that shows some of these shortcuts. 

To drag-and-drop a shortcut to link a URL: 

1. From the View menu, choose Vista > Flat or click the 
toolbar icon to set the mode. 

2. Drag a URL shortcut from the Asset Browser or a local 
directory onto the open vista in the Viewport. A small 
rectangle appears on the vista with four corner handles 
and the name of the URL inside. A hotspot link appears 
in the Project Manager in the Flat folder within the vista 
folder. 

3. Double-click the link in the Viewport or right-click the 
link in the Project Manager and choose Properties from 
the shortcut menu. The Hotspot Properties dialog box 
appears. The External Link option is selected and your 
URL appears in the URL field. 
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4. Type a name for the link in the Element Name field. 

5. To change the URL for the link, type a new URL. 

6. To set this HTML page to appear in a new browser 
window or to target a specific frame in the page, type a 
name in the Frame field. 

7. When you’re done setting properties, click OK. 

USING THE HOTSPOT BUTTON 

If you don’t have shortcuts for the URLs you want to link, you 
can use the Hotspot button in the Vista toolbar to create the 
link, then use the Hotspot Properties dialog box to type the URL 
and frame information. 

To use the Hotspot button to link a URL: 

1. From the View menu, choose Vista > Flat or click the 
toolbar icon to set the mode. 

2. Click the Hotspot button in the Vista toolbar, then click 
the vista and drag to size the hotspot link. When you 
release the mouse button, the Hotspot Properties dialog 
box appears. 
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3. Select the External Link option. 

4. In the Element Name field, type a name for the link. 

5. In the URL field, type the URL you want to link. 

6. To set this HTML page to appear in a new browser 
window or to target a particular HTML frame in the page, 
type a name in the Frame field. 

7. When you’re done setting properties, click OK. 

Note: You have the option of setting an internal vista link as 
well as in external link. Both types of links will work when a 
hotspot is clicked. 

 

LINKING ELEMENTS TO VISTAS AND URLS 

You can link elements to vistas and URLs in Flat, 3D, and 
Overlay mode. For elements that appear in Flat mode, you can 
use the Hotspot button to create the links, as described in 
“Creating vista links,” on page 92 and “Linking vistas to URLs,” 
on page 99. 

When you link elements to vistas and URLs in 3D and Overlay 
mode, you won’t see a hotspot when you press the spacebar as 
you pan the vistas in the Viewer. Since you can’t see these 
links in the viewer, they are best used for things like navigation 
buttons to move back and forward between vistas, or for a 
company logo that, when clicked, displays the company’s home 
page. 
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To link elements to a vista or URL: 

1. In the Viewport, double-click the element you want to 
link. You can also right-click the element in the Project 
Manager and choose Properties from the shortcut menu. 
The properties dialog box appears for the type of 
element. 

2. Click Action. The Hotspot Properties dialog box appears. 

 

• To create a vista link, select the Vista Link option 
and choose a vista to link in the Destination 
drop-down list. Then click Transition to display 
the Link Transition dialog box. Finish the link 
procedure as described in “Setting the link 
transition” on page 96. 

• To create a link to a URL or another HTML page, 
select the Add Hyperlink option. In the URL field, 
type the URL; in the Frame field, type a name if 
you want the HTML page to appear in a new 
browser frame, or to target a specific HTML 
frame. 
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3. When you’re done setting link properties, click OK. 

Note: You have the option of setting an internal vista link as 
well as in external link. Both types of links will work when a 
hotspot is clicked. 

 

EDITING LINKS 

You can change any link by editing the link properties. This is 
handy for easily rerouting your links to vistas and HTML pages. 
For example, you might want to change the navigation between 
vistas or open a different Web page from a particular element 
in your project. 

To edit a link: 

1. Display the Hotspot Properties dialog box by doing one 
of the following: 

• Double-click a link in the Viewport, or select a 
link icon in the Project Manager and choose 
Properties from the shortcut menu. The Hotspot 
Properties dialog box appears. 

• Double-click an element in the Viewport, or select 
an element icon in the Project Manager and 
choose Properties from the shortcut menu. The 
Properties dialog box appears for that type of 
element. Click Action to display the Hotspot 
Properties dialog box. 

2. To change the vista to which you’re linking, choose a 
vista from the Destination drop-down list. 
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3. To change the link transition settings, click the 
Transition button and follow the procedure as described 
in “Setting the link transition” on page 96. 

4. To change the external link, type a new URL in the URL 
field and change or delete the name in the Frame field. 

5. When you’re done editing properties, click OK.
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CHAPTER 6: Publishing Your Project 

Reality Studio makes it easy for you to export all of the files 
you need to publish your finished world on the Web. Reality 
Studio exports IVR and HTML files, along with the associated 
files necessary to play your world in the Plug-in Viewer or Java 
Viewer in a Web page. Reality Studio also makes it easy for you 
to upload your finished world either to remote Zoom Image 
Server or to a local Zoom Image Server. For more information 
on the Zoom Image Server, read the Zoom Image Server User 
Guide in the Documentation folder on the Reality Studio CD. 

The IVR file contains all of the information that the Viewer uses 
to display your world, and the HTML file contains the HTML 
code that loads the Plug-in Viewer or Java Viewer. After you 
export your files, you can copy the HTML from the exported file 
into the HTML file for your Web page. 

Note: For more information about IVR files, see “About the IVR 
file” on page 124. 

You can also choose to export all of your files to the CD Ready 
format. Reality Studio will prepare all the necessary files you 
need to put onto a CD-ROM which you can burn and execute 
your project. 

 

SETTING PROJECT PROPERTIES 

Before you export your files, check and adjust your project 
properties, since these settings affect how your project appears 
in the Web page and plays in the Plug-in Viewer or Java Viewer. 
It’s important to set the dimensions for the Viewer window in 
your Web page, since the size of the viewer window determines 
the viewing area for your world. 
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To set project properties: 

1. In the Project Manager, right-click the project folder and 
choose Properties from the shortcut menu. The Project 
Properties dialog box appears. 

 

2. Set the dimensions for the Viewer in the Web page by 
typing the number of pixels for the width and height for 
the player size. The default viewer dimensions are 400 
pixels wide by 300 pixels high. 

3. The Orbit field is an advanced Reality Studio feature that 
lets you “walk” around objects positioned at the center 
of the vista. The default orbit radius is 0°, which means 
that you’ll be pivoting at the center of the vista. To set 
the orbit at a greater distance from the center of the 
vista, enter a larger value for the orbit radius. 

4. To set the vistas to rotate automatically when they first 
appear in the viewer, leave the Auto-rotate checkbox 
selected. To set the vistas to rotate only when you use 
the pointer to pan across them manually, deselect the 
Auto-rotate checkbox. 
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5. From the Initial Vista drop-down list, select the first 
vista to display in the viewer. 

6. To set the initial view, click View Direction. The Initial 
View dialog box appears. 

 

7. Drag the pointer to navigate the vista and set the pitch 
and yaw values. These values change as you pan around 
the vista. You can also type in the values for each one. 

8. To set the field of view value (proximity of the 
viewpoint), press Shift to decrease the field of view 
(zoom in) and CTRL to increase the field of view (zoom 
out), or type in the values. 

Pitch, yaw, and field of view values describe the 
viewpoint of the vista horizontally (X axis), vertically (Y 
axis), and in depth or proximity (Z axis). 

Pitch—Moves the view up or down (rotates the viewpoint 
around the X axis by degrees). 

Yaw—moves the view right or left (rotates the viewpoint 
around the Y axis by degrees). For example, if your 
panorama has a 360° field of view, the Yaw values span 
from 0° to 360°. 
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Field of view—sets the viewpoint closer or farther away. 

For more information about the X, Y, and Z axes, see 
“Adding elements in 3D mode” on page 65. 

9. When you’re finished setting the initial view, click OK. 

10. If desired, type copyright and note information in the 
appropriate fields in the Project Properties dialog box. 

11. Click OK to save your settings and close the Project 
Properties dialog box. 

Note: If you’re exporting for CD-ROM content only and not for 
the Web, you can skip the next section, “Specifying remote 
path names,” on page 118 and proceed to “Exporting the files” 
on page 112. 

 

EXPORTING THE FILES 

When you export your files, you can choose to export for either 
the Plug-in Viewer, the Java Viewer or to the CD Ready Target. 
The Plug-in Viewer supports all of the features available in 
Reality Studio, so you should choose this option if you added 
elements to your world in addition to hotspots. If you only used 
vistas with hotspot links between them, you can export for the 
Java Viewer. 

EXPORTING FOR THE PLUG-IN VIEWER 

When you export for the Plug-in Viewer, your site visitors will 
use the plug-in with Netscape Navigator® or Microsoft Internet 
Explorer®. Reality Studio exports a button graphic for your 
Web pages that makes it easy for your visitors to download the 
viewer from the iseemedia website. 
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To export for the Plug-in Viewer: 

1. Save your project to make sure any recent changes are 
in effect. 

2. From the File menu, choose Export > Plug-in Target or 
click the toolbar icon. Reality Studio creates a folder with 
the name Myproject_IVR in the same directory as your 
RSD project file, and exports the following files: 

• An Image Worlds (IVR) file with the same name 
as your RSD file, for the Viewer to use to play 
your world. 

• An HTML file with the same name as your RSD 
project file that shows your initial vista playing in 
the Viewer and contains the HTML code for you to 
copy into the HTML file for your Web page. 

• All of the media files and IVR files associated with 
your project vistas and elements.  

• A separate folder named “Export” that contains 
Flashpix images with specified remote paths. If 
you haven’t used remote paths, you won’t see an 
“Export” folder. See “Specifying remote path 
names” on page 118. 

 

EXPORTING FOR THE JAVA VIEWER 

If your finished project consists only of vistas that are linked 
together by hotspots, you can export as a Java applet, to be 
used with the Java Viewer. When you export as a Java applet, 
your site visitors don’t need to download or install a plug-in to 
view your vistas; the Java Viewer and your Reality Studio world 
appear automatically in your Web pages. 
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To export for the Java Viewer: 

1. Save your project to make sure any recent changes are 
in effect. 

2. From the File menu, choose Export > Java Applet Target 
or click the toolbar icon. Reality Studio creates a folder 
with the name Myproject_Java in the same directory as 
your RSD project file and exports the following files: 

• Image Worlds (IVR) files for each vista in your 
project. 

• A sample HTML file with the same name as your 
project; this file shows the initial vista in your 
project, playing in the Java Viewer.  

• Individual HTML files for each vista in your 
project. 

• A panoapplet.jar file that contains the entire Java 
applet files for the Internet Explorer client. 

• An Export folder that contains Flashpix images, 
which must have specified remote paths. If you 
haven’t specified remote paths for Flashpix 
images, you won’t see an Export folder. See 
“Specifying remote path names” on page 118. 

 

EXPORTING TO THE CD READY TARGET 

Your finished project can be exported to the CD Ready Target. 
The CD viewer allows you to burn all the exported files onto a 
CD-ROM and distribute the CD to anyone you would like to view 
your tour. The exported files can be found at 
Myproject_IVR_CD. 
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To export to the CD Ready Target 

1. Save your project to make sure any recent changes are 
in effect. 

2. From the File menu, choose Export > CD Ready Target 
or click the toolbar icon. Reality Studio creates a folder 
with the name Myproject_IVR_CD in the same directory 
as your RSD project file and exports the following files: 

• Project folder that contains all of the elements that 
are part of your project. 

• vbrun folder; contains the Visual Basic Runtime 
version 6.0 library pack. This must be installed if it is 
not present on the computer that is viewing the tour. 
The user will be prompted if this is required. 

• autorun.inf file; once the files are burnt on to a CD-
ROM, this file will automatically launch the tour once 
the CD is put into the CD-ROM drive. 

• cdview.exe file; the executable file that launches the 
tour. 

• lpcontrol.dll file; the viewer file 

• properties.txt file; lists the values for autospin, 
width, height and background color of the viewer. 
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UPLOADING YOUR PROJECT TO THE ZOOM IMAGE SERVER 

Accompanied with this version of Reality Studio is a limited 
licensed version of the Zoom Image Server.  

When uploading your project to a local Zoom Image Server (i.e. 
on the same machine as Reality Studio), then you will use the 
version of Zoom Image Server that is bundled with the Reality 
Studio. When uploading your project to a remote Zoom Image 
Server (i.e. on a different machine than Reality Studio), then 
you can use either the bundled version or any Zoom Image 
Server Enterprise edition version 4.6 or higher. When using the 
upload command, Reality Studio does everything automatically. 
You don’t have to worry about placing files in the right location. 

To upload your project to a local server: 

1. Save your project to make sure any recent changes are 
in effect. 

2. From the File menu, choose Upload to Server or click the 
toolbar icon. The Upload to Zoom Image Server dialog 
box is displayed. 

 

3. Select the Local Zoom Server checkbox in the Upload 
Target area. 
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4. In the Tour Name field, the default tour name is your 
project name. You can change this by typing the desired 
tour name in the field. 

Note: If you try to upload a project with the same name 
as a previously uploaded project, Reality Studio will 
notify you that the Zoom Image Server will be shut 
down and restarted to complete the upload command.  

5. Select Preview in Web Browser if you want to preview 
your project in a web browser. 

6. Click Ok. 

7. All of the image files associated with your project can be 
located at InstallDirectory\iseemedia\Zoom Image 
Server Reality Studio 4.6\images. The complete project 
file can be found at InstallDirectory\iseemedia\Zoom 
Image Server Reality Studio 
4.6\appserver\webapps\root. 

To upload your project to a remote server: 

1. Save your project to make sure any recent changes are 
in effect. 

2. From the File menu, choose Upload to Server or click the 
toolbar icon. The Upload to Zoom Image Server dialog 
box is displayed. 
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3. Select the Remote Zoom Server checkbox in the Upload 
Target area. 

4. In the Tour Name field, the default tour name is your 
project name. You can change this by typing the desired 
tour name in the field. In URL field, type the URL of the 
remote Zoom Image Server (e.g. 
http://hostname:8087). In the User and Password field, 
type the user name and password granted by the 
administrator of the remove Zoom Image Server. 

Note: If you try to upload a project with the same name 
as a previously uploaded project, Reality Studio will 
notify you that the Zoom Image Server will be shut 
down and restarted to complete the upload command.  

5. Select Preview in Web Browser if you want to preview 
your project in a web browser. 

6. Click Ok.  

7. All of the image files associated with your project can be 
located at InstallDirectory\iseemedia\Zoom Image 
Server Reality Studio 4.6\images. The complete project 
file can be found at InstallDirectory\iseemedia\Zoom 
Image Server Reality Studio 
4.6\appserver\webapps\root. 

 

SPECIFYING REMOTE PATH NAMES 

Note: The difference between specifying remote path names 
and uploading to the Zoom Image Server is how automatic you 
want the process to be. By selecting the upload option, Reality 
Studio will automatically prepare your project and refit the 
dependent links to the Zoom Image Server. By specifying the 
remote path, you will be responsible for ensuring all files have 
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the correct remote path and are placed in the correct location 
for the Zoom Image Server. 

Although you can specify a remote path name for any element, 
it’s most important and most often used for elements that use 
Flashpix images, since these images must be uploaded to the 
Zoom Image Server document root directory. Be sure to use 
remote path names for: 

• Flashpix vistas 

• Flashpix image panels in Flat, 3D, or Overlay mode 

• Flashpix image objects (IMOBs) 

The exported IVR file that the Viewer reads references each 
Flashpix image in your project, so make sure you’ve specified 
the correct and complete remote path for each one. You must 
use the entire URL to the document root directory and not just 
the relative path. Specify the port number for the Zoom Image 
Server, which is configurable; the default port number is 8087. 
Here’s a sample URL for a Flashpix image on a Zoom Image 
Server: 

http://hostname:8087/fif=imagedirectory/Flashpix/myFlashpix.
fpx 

In addition, when you specify a remote path name for Flashpix 
images, they appear in the Export folder in the same directory 
as your other exported files. This makes it simple for you to 
upload your Flashpix images to the Zoom Image Server. 

Note: If you’re running your own Web and Zoom Image 
Server, it will simplify things to create a special directory for all 
Flashpix images. 
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To specify remote path names: 

1. Launch Reality Studio and open your project. 

2. For each element that uses Flashpix, click the element 
icon in the Project Manager and choose Properties from 
the shortcut menu. The Properties dialog box appears 
for the type of element. 

3. In the Remote Path field, type the complete URL for the 
Flashpix image on the Zoom Image Server, including the 
port number, which is configurable. For information on 
server configuration, refer to your Zoom Image Server 
User’s Guide that accompanied your Zoom Image 
Server. 

4. When you’re done, click OK. After you export your files, 
check to make sure that all of your Flashpix images are 
in the Export folder. 

 

PLACING THE HTML CODE IN YOUR WEB PAGE 

The exported HTML file with the same name as your project 
shows your finished world in the Plug-in Viewer or Java Viewer. 
You can use any text editor to open that file, copy the HTML, 
and paste it into the HTML file for your Web page. 

Note: It’s especially useful to assign this HTML to a specific 
frame or table cell in your Web page, so each time the viewer 
content reloads or refreshes, the rest of your Web page isn’t 
affected. 

Here’s a sample of the HTML exported for a Java applet; copy 
only the HTML between the copy command lines: 
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<!--//------------Begin Copy Here---------------//--> 
<center> 
<script language="JavaScript"> 
<!--// 
var browser = navigator.appName; 
var version = parseFloat(navigator.appVersion); 
if (browser == 'Netscape' && version < 4.0) { 
document.write('<applet name="pano" code="pano.class" 
archive="rspanoNS3.zip" width=400 height=300>'); 
} 
else { 
document.write('<applet name="pano" code="pano.class" 
archive="rspano.zip" width=400 height=300>'); 
} 
document.write('<param name=cabbase value="rspano.cab">'); 
document.write('<param name=file value="Beach.ivr">'); 
document.write('<param name=initialView value="0.000000, 
180.000033, 49.999967">'); 
document.write('<param name=hotspot2 value="0.041, 0.329, 
0.058, 0.411, http://www.iseemedia.com/ 
To_Live_Picture_2 New">'); 
document.write('<param name=hotspot3 value="0.101, 0.105, 
0.129, 0.250, .html?initialView=0.000,180.000,50.000 
hs">'); 
document.write('</applet>'); 
//--> 
</script> 
</center> 
<!--//------------End Copy Here---------------//--> 

 

This is some sample HTML from an exported plug-in target; 
copy only the HTML between the copy command lines: 

<!--//------------Begin Copy Here---------------//--> 
<center> 
<embed src="Resort.ivr" type="i-world/i-vrml" width=400 
height=300 autospin=2 name="panoComponent"> 
</center> 
<!--//------------End Copy Here---------------//--> 
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This HTML assumes that all of your exported Reality Studio 
media and related files for your Web pages are in the same 
directory. If you have your Web pages in a separate directory, 
be sure to specify the path to all of the exported files 
referenced by the HTML you’re copying. If you don’t, the Viewer 
won’t be able to retrieve and display your entire world. 

PLACING YOUR FILES ON THE WEB 

If you haven’t used any Flashpix images in your project, you 
can upload all of your exported files and HTML files to your Web 
server root directory, as usual. However, if you’ve used 
Flashpix images, you must upload them to the Zoom Image 
Server document root directory. For details on using the upload 
command see “Uploading your project to the Zoom Image 
Server” on page 116 or “Specifying remote path names” on 
page 118. 

Note: When you export your files, those with remote path 
names specified are saved to an Export folder. This places all of 
your Flashpix images in one folder that you can easily upload to 
the Zoom Image Server. 

CONFIGURING THE MIME TYPE 

To configure a Web server to recognize and display the IVR files 
Reality Studio exports, you need to add the Multi-part Internet 
Mail Extension (MIME type). If you’re using an Internet Service 
Provider (ISP), you can give them the iseemedia IVR MIME type 
to add to their server. If you administer your own Web server, 
consult your server software documentation for instructions on 
adding and configuring MIME types. 

IVR MIME Type IVR file extension 

i-world/i-vrml .ivr 
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CHAPTER 7: Behind the Scenes 

Reality Studio uses Virtual Reality Modeling Language (VRML) 
and the iseemedia extensions to VRML 2.0 to create the IVR 
files the Viewer uses to display your worlds on the Web. If you 
are familiar with VRML, you can edit the exported IVR file to 
add more features to your world. For those of you who do not 
know VRML, this chapter gives you a brief summary of VRML 
and resources you can consult to learn more. It also describes 
the iseemedia extensions to VRML 2.0 that Reality Studio 
supports, and provides advanced techniques for enhancing your 
worlds. 

 

ABOUT VIRTUAL REALITY MODELING LANGUAGE (VRML) 

Virtual Reality Modeling Language (VRML) is an International 
Standards Organization (ISO) standard for describing three-
dimensional virtual worlds on the Internet. The IVR file that 
Reality Studio exports contains is a standard VRML 2.0 file with 
EXTERNPROTO nodes for the iseemedia extensions.  

Note: For information about the iseemedia extensions to VRML 
2.0, see “iseemedia Image Worlds nodes” on page 124. 

The Viewer displays IVR files and supports core VRML 2.0 
nodes, with limited support for VRMLScript. You can find many 
books about VRML in the computer section of your local book 
store. For more information and a list of links to other VRML 
sites, consult the following Web resources: 

• The VRML 2.0 Specification is at 
http://tecfa.unige.ch/guides/vrml/vrml2/spec/part1/sco
pe.html. 
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• The most up-to-date information about VRML is on the 
VRML Repository site at 
http://www.web3d.org/vrml/vrml.htm. 

 

HOW REALITY STUDIO USES VRML 

When you use Reality Studio to create a world with various 
scenes and elements, Reality Studio automatically writes the 
VRML file for you, which saves you time and lets you 
concentrate on the visual design of your project. The Viewer 
reads this file to display your world. 

ABOUT THE IVR FILE 

The IVR files Reality Studio exports are VRML 2.0 compliant and 
have the .ivr file extension. Each element you add to your 
project generates corresponding VRML code. Some elements 
use the iseemedia Image Worlds extensions, via the VRML 2.0 
EXTERNPROTO interface. Photovista and Photovista 3D Objects 
also create IVR files for use with the Viewer. 

ISEEMEDIA IMAGE WORLDS NODES 

Using the iseemedia Image Worlds nodes, you can add unique 
features to your virtual worlds. For example, you can rotate an 
object to view all sides or use photographic panoramas as the 
background for your scenes. The Image Worlds nodes that 
Reality Studio currently uses are: 

• IMOBSensor 

• ScreenElement 

• SlideShowTexture 

• Vista 
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IMOBSensor 

An IMOBSensor works with an image object (IMOB) in 3D mode 
(also referred to as a World IMOB), which is a collection of 
images of a 3D object, taken from various angles around the 
object. During playback, you can manipulate the IMOB to 
change which image displays, which gives the impression of 
examining an actual 3D object. Reality Studio creates an 
IMOBSensor for each World IMOB in your project. 

Note: Photovista 3D Objects, which is part of your Reality 
Studio suite, lets you create IMOBs easily. See the Photovista 
3D Objects User’s Guide or online Help for information. 

The primary function of the IMOBSensor is to determine which 
image to show based on various factors, including the object’s 
position, animation, and interaction with the user. The 
IMOBSensor also generates events when you interact with the 
World IMOB in any way. 

ScreenElement 

A ScreenElement has no equivalent in VRML 2.0. It is a piece of 
geometry that lives in a screen space, not in the 3D 
environment. Its texture coordinates are in pixels, not in 
Cartesian units. It responds to translation transformations, but 
ignores the “z” value of the translation. Reality Studio uses 
ScreenElements for panels and image objects (IMOBs) in 
Overlay mode (also referred to as Screen IMOBs). 

SlideShowTexture 

A SlideShowTexture is a cross between a standard VRML 
ImageTexture and MovieTexture. The SlideShowTexture 
contains multiple frames, similar to the MovieTexture, but is 
played differently than a MovieTexture in that you can either 
set the SlideShowTexture to show a frame or advance by a 
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specified number of frames. Reality Studio uses 
SlideShowTextures for IMOBs in 3D mode. 

Vista 

A Vista defines an image panorama, which you navigate by 
pivoting the view from a centerpoint. Typically, several Vistas 
are at the top level of the VRML file along with some script 
nodes so you can jump between panoramas by adding links 
between the vistas. Vistas are the backbone of all Reality 
Studio projects. 

SUPPORTED IMAGE WORLDS AND VRML NODES 

Reality Studio supports all of the standard VRML 2.0 nodes and 
most of the iseemedia Image Worlds nodes. The following table 
describes the nodes associated with each element in a Reality 
Studio project. 

Element Generated VRML nodes 

Vista • Vista node with an ImageTexture 
attribute 

• Switch node, which turns on the 
Vista's children (panels, for example) 
when you view the Vista 

• Viewpoint node, which controls your 
field/ direction of view when you view 
the Vista 

Hotspot Special VRMLScript, which activates the 
vista and viewpoint for the destination. 

Image panel in Flat 
mode 

Shape node composed of a four-point 
(rectangular) IndexFaceSet Geometry 
element with an ImageTexture Appearance 
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Element Generated VRML nodes 

Image panel in Overlay 
mode 

Shape node, composed of a 
ScreenElement Geometry element with an 
ImageTexture appearance node and a 
script node that turns it on/off, and 
optionally triggers events when clicked. 

Movie panel in Flat 
mode 

• Shape node composed of a four-point 
(rectangular) IndexFaceSet Geometry 
element with a MovieTexture 
Appearance 

• Sound node 

Movie panel in Overlay 
mode 

Shape node, composed of a 
ScreenElement Geometry element with a 
MovieTexture appearance node and a 
script node that turns it on/off and 
optionally triggers events when clicked. 

IMOB in Overlay mode Shape node with a ScreenElement 
Geometry element and a 
SlideShowTexture node. 

IMOB in 3D mode IMOBSensor node, SlideShowTexture 
node, and Billboard node. 

Geometry object in 3D 
mode 

Inline node. 

Sound Sounds node. 

 

Note: Reality Studio supports third-party VRML authoring tools 
that generate core VRML 2.0 files. You can use these VRML 
(WRL) files by adding them to your Reality Studio projects in 
3D mode. The VRML content created by some VRML tools might 
not be supported. 
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ADDING IMAGE WORLDS NODES TO WRL FILES 

You can add the Image Worlds nodes to VRML 2.0 (WRL) files 
by including the EXTERNPROTO declaration for the image world 
nodes at the beginning of the WRL file. When you’re done, 
change the file extension to .ivr so the Viewer will be able to 
display it.  

Here’s an example of the EXTERNPROTO declaration for a vista 
from a Reality Studio exported IVR file: 

#VRML V2.0 utf8 
EXTERNPROTO Vista [ 
exposedField SFString type 
exposedField MFNode texture 
exposedField MFVec2f vFov 
exposedField MFVec2f hFov 
exposedField SFVec2f pitchRange 
exposedField SFVec2f yawRange 
exposedField SFVec2f zoomRange 
exposedField MFColor groundColor 
exposedField MFFloat groundRange 
exposedField MFColor skyColor 
exposedField MFFloat skyRange 
exposedField MFNode children 
eventOut SFVec2f clickPt 
eventOut SFVec2f overPt 
eventOut SFBool isBound 
eventIn SFBool set_bind 
] "http://www.iseemedia.com/proto/ 
vistaproto15.wrl#Vista" 

Reality Studio exported IVR files comply with version 1.5 of the 
Image Worlds Specification. The URL at the end of the example 
above indicates this compliance as vistaproto15. 
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ADVANCED TECHNIQUES 

If you know how to write VRML, there are additional functions 
you can add to your world. This section gives you some tips on 
achieving some of the most commonly desired effects. 

EDITING THE IVR FILE 

The IVR files Reality Studio creates are compliant with core 
VRML 2.0 and you can use any text editor to edit the exported 
IVR file. However, make sure you’re done working on your 
project before you do this, because Reality Studio will overwrite 
the changes to your IVR file when you save or export your 
project again. 

Note: This release of Reality Studio will only load the vista 
nodes in IVR files, such as those files created in Photovista. 
Reality Studio will not load any other node that is in the IVR 
file. 

ACHIEVING MULTIPLE EFFECTS FROM A SINGLE HOTSPOT 

You can have multiple actions occur when you click a hotspot. 
For example, you can click a hotspot to display an image, open 
an HTML frame, and play a sound— all at the same time. 

Reality Studio creates a VRMLScript node with eventOut fields 
that you can route to one or more events. After you’re done 
working on your project and export the final IVR file, you can 
use any text editor to add additional routes as defined in the 
VRML 2.0 Specification.
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Appendix A: Troubleshooting 

This troubleshooting section describes the solutions to some of 
the common situations you might encounter when working in 
Reality Studio. For the latest troubleshooting tips and the 
answers to frequently asked questions (FAQs) about Reality 
Studio, visit the iseemedia website at www.iseemedia.com. 

Situation Solution 

I can’t drag an asset into 
the Viewport or Project 
Manager to create an 
element. 

Make sure you’re working in the 
correct view mode to add that 
type of asset. For example, to 
add 3D objects, you must be 
working in 3D mode. See 
“Adding Elements in Flat, 3D, 
and Overlay mode” on page 50. 

I can’t see the content of 
the panel; the tracker 
appears empty. 

You’re viewing the panel in Flat 
mode. To see the image content 
of the panel, switch to 3D mode. 
See “Adding Elements in Flat, 
3D, and Overlay mode” on page 
50. 

The hotspot button on the 
Vista toolbar appears 
dimmed. 

You can only add hotspots in Flat 
mode. See “Adding Elements in 
Flat, 3D, and Overlay mode” on 
page 50. 
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Situation Solution 

When I click a tab in the 
Asset Browser, the asset 
icons appear dimmed. 

Switch to the view mode that 
accepts that type of asset and 
the icons will no longer appear 
dimmed. See “Adding Elements 
in Flat, 3D, and Overlay mode” 
on page 50. 

I added a geometry 
element to my project 
and I can see it in the 
Project Manager, but it 
doesn’t appear in the 
Viewport. 

The distance is set too close to 
the origin of the viewpoint or the 
object is too small to appear. 
Right-click the element in the 
Project Manager to show the 
Geometry Properties dialog box, 
then reset the distance and scale 
properties. 

I can’t use Reality Studio 
to open IVR files I created 
using Photovista. 

Reality Studio only opens and 
displays RSD project files. If you 
drag your IVR file into the 
Viewport, it will read the vista 
node to add a vista to your 
project. 

My VRML 1.0 objects 
don’t appear when I drag 
them into the Viewport in 
3D mode. 

Reality Studio supports VRML 2.0 
and the iseemedia Image Worlds 
File Extensions. See “Chapter 7, 
Behind the Scenes” on page 123. 

I added an element that 
is so large I can’t see my 
vista. 

Double-click the element to show 
the properties dialog box, then 
type a smaller number in the 
Scale field. 
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Situation Solution 

Why is the World Map 
showing in my browser 
preview and the exported 
HTML page? 

When you add a background 
image to the World Map, it 
appears in the HTML page when 
you do a browser preview or 
export. When you copy the 
specified HTML code from the 
exported file into your own Web 
page to show your project, the 
World Map won’t appear. 

When I click a hotspot to 
an HTML page (external 
link), it replaces the 
browser content and I 
can’t see my project. 

Double-click the link in the 
Viewport to show the Hotspot 
Properties dialog box. Type a 
name in the Frame field to open 
a new browser frame when you 
click the link, then click OK. 

I added a sound in 
Overlay mode and I don’t 
see a sound element in 
the Viewport. 

Sounds are ambient in Overlay 
mode and don’t have a position 
in the space, so you won’t see 
the sound element in the 
Viewport. An Overlay sound 
plays at the same volume no 
matter where you pan in the 
vista. If you want to change 
sound volume and position, add 
a sound in 3D mode. See 
“Adding a sound in 3D mode” on 
page 77. 
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Glossary 

3D mode 

One of the view modes for vistas. Lets you place, position, and 
size elements in the 3D space. The elements appear to have 
dimension within the 3D space, rather than fixed in position on 
the background panorama. 

Animated GIF 

A series of Graphics Interchange Format (GIF) images used to 
create an animation optimized for Web viewing. See GIF. 

Asset 

A media file that has been prepared for use in Reality Studio, 
such as creating thumbnail images for previewing the asset in 
the Asset Browser. 

Asset Browser 

Shows and organizes the asset collections available for all of 
your Reality Studio projects. You can drag assets from the 
Asset Browser into the Project Manager or onto vistas in the 
Viewport. 

AVI 

Microsoft’s Audio/Video format. You can use these files as 
movies, sounds, panoramas, or slide shows. 

Bitmap (BMP) 

Native Windows image files. For the Internet, GIF and JPEG 
images provide better compression and are more widely used. 
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Browser preview 

Previewing your Reality Studio project in an HTML page with 
the Viewer. 

Chroma key 

The chroma key lets you choose a color to “key out” of an 
image, thus permitting the background image to show through. 
For example, if you have an image of a bird in flight against a 
black background, you can place that image as a panel onto a 
panorama of the sky and key out the color black. The black 
background in the image panel becomes invisible and the bird 
appears against the background of the sky. 

Element 

When you add an asset, such as an image or movie, to a 
Reality Studio project, it becomes an element in the project. 
Each element has properties related to the view mode in which 
you add it—Flat, 3D, or Overlay—and appears in the Project 
Manager, as well as the Viewport. 

External link 

A link to a URL or another HTML page. By specifying the frame 
for an external link, you can replace the content of the current 
browser window or open a new browser window to display the 
page. 

Field of view 

The size of the angle you can see from a given perspective. 
When you increase the field of view for a vista, you decrease 
the vista view (as when you zoom in to see more detail, but 
less of the panoramic image). When you decrease the field of 
view for a vista, you increase the vista view (as when you zoom 
out to see a larger portion of the panoramic image). 
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File extensions 

Windows applications use file extensions to recognize and open 
files. The following table shows the file extensions for the media 
types that Reality Studio uses. 

Media type File extension 

Audio file .au 

Audio Interchange File Format .aiff 

Bitmap .bmp 

Flashpix .fpx 

GIF .gif 

JPEG .jpg 

Microsoft’s Audio/Video format .avi 

MIDI .mid 

MP3 .mp3 

MPEG .mpg 

QuickTime .mov 

Waveform .wav 
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Flashpix 

A hierarchical image file format that provides multi-resolution 
imaging for fast, photo-realistic presentations on CD-ROMs and 
the Internet. You can view the image at one resolution on your 
computer screen and zoom in to higher resolutions to see 
greater levels of detail. The Flashpix file format lets you work 
with high quality images without using a significant amount of 
memory and storage space. 

The following graphic illustrates the Flashpix image hierarchy, 
also referred to as an image pyramid. 

The base of the pyramid represents the source image, such as 
a GIF or JPEG. What makes the Flashpix file unique are the 
other levels in the pyramid. As you move up through the 
pyramid, each image is half the size (in both width and height) 
of the image below. In addition, each image in the pyramid is 
split into tiles that are 64 x 64 pixels. 

In order to use Flashpix images on the Internet, your Web 
server must be running the Zoom Image Server. For more 
information about Flashpix, visit http://www.i3a.org. 

Flashpix object 

An image object (IMOB) that is composed of Flashpix images, 
so you can zoom in to access higher resolutions and more 
details when viewing. See Flashpix and Image object. 

Flashpix vista 

A vista that has a Flashpix image for the panorama, so you can 
zoom in to access higher resolutions and more details when 
viewing. See Flashpix and Vista. 
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Flat mode 

One of the view modes for vistas. Lets you place, position, and 
size elements in the panoramic space. 

FOV 

See Field of view. 

Frame 

A rectangular image to be used as a border for the Viewer 
window in the Web page. 

Geometry object 

3D object represented by geometric primitives and texture 
maps. You add, position, and size geometry objects in 3D 
mode. 

Group 

A way of organizing Overlay elements in order to achieve 
effects such as hiding or showing elements at different times. 

GIF 

Graphics Interchange Format. This popular image file format, 
created by Compuserve, Inc., is used for 256 color images in 
Web pages. This format is best suited for use with icons, logos, 
and diagrams. 

Hotspot 

An area in a vista that, when clicked in the Viewer, causes a 
new action to happen. For example, you can use hotspots to 
link panoramas, load a new HTML page, and play audio clips. 
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Image object (IMOB) 

A collection of photographic images of a real-world 3D object, 
taken from various angles around the object. During playback, 
you can manipulate the IMOB to determine which image to 
display. This simulates the experience of examining an actual 
3D object. 

Image World nodes 

The iseemedia extensions to VRML 2.0. 

Image Worlds Specification 

A document that describes the iseemedia extensions to VRML 
2.0, shows examples of each new node, and lists scripts that 
work with the Viewer. 

IMOB 

See Image object. 

Initial view 

The first viewpoint in the vista to appear. When you set the 
initial view, you can also set the viewpoint for the vista. See 
Viewpoint. 

In-viewer link 

A link that, when clicked, causes an action in the Viewer, such 
as clicking a doorway to move to another vista. The content 
changes in the viewer only. When you link vistas, you are 
creating in-viewer links. 



Glossary 

 139

IVR file 

Image-based Virtual Reality file. A text file in VRML 2.0 format 
that contains the Image Worlds Extensions to VRML 2.0. Reality 
Studio exports an IVR file, which the Viewer uses to play the 
world you created.  

Java applet 

Applet written in Java programming language; in Reality 
Studio, exported files for use with the Java applets display in 
Web pages without using browser plug-ins. 

Note: The Java Viewer only supports JPEG panoramas and 
hotspot linking, ignoring all other elements in your project. 

JPEG 

Joint Photographic Experts Group. The preferred image format 
for the Internet, because JPEG provides the best compression 
available and you can download and display JPEGs 
progressively, which lets you view the image as it is 
downloading. 

Layer 

A way of organizing Overlay elements numerically to appear in 
front of or behind each other. 

Linking 

Creating a hypertext link between vistas, objects, and HTML 
pages. For example, linking lets you switch between vistas or 
show the home page of a hotel when you view a vista of one of 
the hotel rooms. You can denote a link with a hotspot that 
appears as a bull’s eye in the Viewer when you press the 
spacebar. 
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Media types 

The media that Reality Studio uses to create assets. Media 
types can be images, movies, panoramas, and so on. 

Orbit radius 

The orbit radius designates the offset of the user’s viewpoint 
relative to the center of a vista. This lets users “walk” around 
objects placed at the center of a vista. 

Overlay mode 

Overlay mode lets you place stationary elements on top of a 
vista, so the elements always remain visible wherever you 
scroll. 

Panel 

Rectangular objects that you insert into vistas in Flat and 
Overlay modes. You can position and warp panels in Flat mode, 
but they stay fixed on top of the scene when you insert them in 
Overlay mode. 

Panorama 

A photograph with a wide view along the horizon. Panoramas 
are the background images for the vistas in Reality Studio. See 
Field of view for more information. 

Panoramic space 

The background space of a panorama. When you add, position, 
and warp elements in the panoramic space they appear 
attached to the background panorama. An example is an image 
that appears fixed in a position on a wall. 
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Photovista Panorama 

iseemedia’s application for stitching digital images into 
panoramas. 

Photovista 3D Objects 

iseemedia’s application for creating and editing object movies, 
which are composed of a series of digital images of a 3D object. 

Pitch 

A value that moves the vista viewpoint up or down (rotates the 
viewpoint around the X axis by degrees). You set the pitch for a 
vista in the Initial View dialog box, which you access through 
the Project Properties dialog box. 

Plug-in target 

Exported files in Reality Studio that play in the Plug-in Viewer 
for Web browsers. Browser plug-ins load and play media, such 
as movies and sounds. 

Project 

A Reality Studio project consists of one or more vistas with 
elements and links. When you save your project, Reality Studio 
outputs an RSD file. 

Project Manager 

Shows an overview of all of the scenes in your project, 
organized in a directory-like structure with folders you can 
expand and collapse to view the elements inside. Each top-level 
folder contains a vista with Flat, 3D, and Overlay folders. 
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Publish 

For publishing your project on the Web, you export an IVR and 
HTML file and all of the media files that make up the elements 
in your project. The Viewer reads the IVR file to display your 
world in the HTML page. 

Quick preview 

Previewing your Reality Studio project in an internal viewer 
window running the Plug-in Viewer. 

QuickTime 

Apple Computer's Audio/Video format. You can use these files 
as movies, sounds, panoramas, or slide shows. 

Remote path 

The path to a remote file for an element or to the Zoom Image 
Server for Flashpix images; the remote path appears in the 
Properties dialog box for vistas and elements. 

RSD file 

Reality Studio Designer file. This is the file that Reality Studio 
outputs when you save your project. The file extension is .rsd. 

Scenes 

A scene comprises a vista with all of its elements. A project 
consists of scenes that you link together to create a world. 

Scripted movie 

VRML (WRL) files that contain VRML Script that adds behaviors, 
such as a bird that appears to fly closer and farther away in a 
vista. 
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Sound 

A sound file, usually WAV, used as an asset. 

URL 

Uniform Resource Locator. The URL is a map to a Web object. It 
describes the location and name of the object file, and the path 
used to access it. 

Viewpoint 

The point in the vista you see when you view it in the Viewer. 
The viewpoint consists of pitch, yaw, and field of view values. 
See Field of view, Pitch, and Yaw. 

Viewport 

The main window of Reality Studio, where the open vistas 
appear. You can drag and drop assets into vistas in the 
Viewport to create elements in your project. 

Vista 

A vista defines an image panorama that you view by “standing 
in its center” and pivoting the view direction. Vistas are the 
foundation of Reality Studio projects and make up the scenes in 
your world. A vista node is one of the iseemedia extensions to 
VRML 2.0.  

Vista link 

A link between two vistas. 
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VRML 

Virtual Reality Modeling Language. A scene description 
language for creating and exploring 3D environments on the 
Web. The current version that Reality Studio supports is VRML 
2.0. 

Warping 

Moving a panel in Flat mode so it conforms to the contours of 
the panorama that is the background in the vista. To warp a 
panel, press Alt while dragging the panel into position. 

Waveform (WAV) 

A Windows standard audio file format. 

World 

Your world is all of the scenes in your project and any elements 
contained within the scenes. For example, if you are creating a 
house, the world is your finished house with all the rooms that 
you can walk through. 

World Map 

A pane in Reality Studio that shows an overhead view of the 
vistas in your project, representing each vista as a round node 
on a plane. The World Map gives you perspective on the scenes 
in your world and shows the links between each vista. 
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Yaw 

A value that moves the vista viewpoint right or left (rotates the 
viewpoint around the Y axis by degrees). For example, if your 
panorama has a 360° field of view, the Yaw values span from -
360° (left side of the panorama) to +360° (right side of the 
panorama). You set the yaw for a vista in the Initial View dialog 
box, which you access through the Project Properties dialog 
box.
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Index 

Numerics 
3D mode, 33, 52, 133 

adding elements, 52, 65 
adding geometry elements, 71 
adding image objects, 72 
adding panels, 75 
adding sounds, 77 
edit geometry properties, 83 
edit image objects properties, 83 
edit sound properties, 87 

A 
actions 

assigning, 89 
hide, 89 
loop, 89 
play, 89 
setting trigger element, 90 
show, 89 
toggle show, 89 

adding vistas, 46 
Adobe Photoshop, 13 
AIFF files, 37 
animated GIF, 37, 133 
asset browser, 17, 133 

docking, 36 
hide, 36 
show, 36 
using, 34 

asset collections, 17 
create custom, 36 

asset toolbar, 35 
add collection icon, 35 
back icon, 35 
refresh icon, 35 
remove collection icon, 35 

assets, 31, 133 
frames, 31 
geometry, 31 
image objects, 31 

panels, 32 
sounds, 32 
URL links, 32 
vistas, 32 

AU files, 38 
AVI, 133 
AVI files, 38 

B 
bitmap, 133 
Bitmap files, 38 
BMP files. See Bitmap 
browser preview, 134 

C 
CD ready target 

exporting to, 115 
chroma key, 134 
components, Reality Studio, 16 
cut, 102 

E 
edit menu, 21 
element properties 

editing, 79 
elements, 31, 57, 61, 134 

3D mode, 52 
adding, 63 
adding in 3D mode, 65 
adding in flat mode, 64 
adding in overlay mode, 66 
assigning actions, 57, 89 
edit properties in overlay mode, 85 
editing media files, 92 
flat mode, 51 
frames, 31 
geometry, 31 
image objects, 31 
linking to URLs, 105 
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linking to vistas, 105 
overlay mode, 54 
panels, 32 
sounds, 32 
URL links, 32 
vistas, 32 

exporting, 112 
CD ready target, 114 
Java Viewer, 113 
plug-in viewer, 112 

external link, 134 

F 
features, Reality Studio, 14, 30 
field of view, 101, 134 
file extensions, 135 
file menu, 19 
files 

exporting, 112 
placing on the web, 122 

Flashpix, 38, 136 
using, 39 

Flashpix object, 136 
Flashpix vista, 136 
flat mode, 33, 51, 137 

adding elements, 51, 64 
adding panels, 74 

FOV. See field of view 
FPX files. See Flashpix 
frame, 137 
frames, 31, 64, 69 

adding in overlay mode, 69 

G 
geometry, 31, 64 

adding in 3D mode, 71 
edit properties in 3D mode, 83 
elements, 70 
node, 127 

geometry object, 137 
GIF, 137 
GIF files, 38 
groups, 67, 137 

adding overlay elements, 68 

H 
help menu, 24 
hotspot, 137 

multiple effects, 129 
node, 126 

HTML code 
placing on web page, 120 

I 
image objects, 31, 64, 72, 138 

adding in 3D mode, 72 
adding in overlay mode, 73 
edit properties in 3D mode, 83 
node, 127 

image panel 
node, 126 

image world 
supported nodes, 126 

image world nodes, 124, 138 
IMOBSensor, 124 
ScreenElement, 124 
SlideShowTexture, 124 
vista, 124 

image world specification, 138 
IMOBs. See image objects 
IMOBSensor, 125 
initial view, 111, 138 
insert objects toolbar, 29 
in-viewer link, 138 
IVR file, 124, 139 

editing, 129 

J 
Java applet, 139 
Java Viewer 

exporting to, 113 
JPEG, 139 
JPEG files, 38 
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L 
layers, 67, 139 

adding overlay elements, 69 
link transition, 100 
linking, 139 
linking vistas, 48 
links 

editing, 107 

M 
media files 

editing, 92 
media types, 140 

AIFF, 37 
animated GIF, 37 
AU, 38 
AVI, 38 
BMP, 38 
Flashpix, 38 
GIF, 38 
JPEG, 38 
MIDI, 38 
MP3, 38 
MPEG1, 38 
MPEG4, 38 
QuickTime, 39 
supported types, 37 
WAV, 39 

menus, 18 
edit menu, 21 
file menu, 19 
help menu, 24 
tools menu, 23 
view menu, 22 
window menu, 24 

MIDI files, 38 
mime type 

configuring, 122 
movie panel 

node, 127 
MP3 files, 38 
MPEG1 files, 38 
MPEG4 files, 38 

O 
orbit radius, 140 
overlay groups 

assigning actions, 89 
overlay mode, 33, 53, 140 

adding elements, 53, 66 
adding frames, 69 
adding image objects, 73 
adding panels, 76 
adding sounds, 78 
edit element properties, 85 
edit sound properties, 87 

P 
pan, 102 
panels, 32, 64, 74, 140 

adding in 3D mode, 75 
adding in flat mode, 74 
adding in overlay mode, 76 
edit properties in 3D mode, 81 
edit properties in flat mode, 81 

panorama, 140 
panoramic space, 140 
Photovista, 141 
Photovista 3D Objects, 141 
pitch, 101, 141 
plug-in effects, 93 

dialog box, 93 
Plug-in target, 141 
plug-in viewer 

exporting to, 112 
previewing projects, 59 

browser preview, 60 
quick preview, 59 

project, 141 
adding vistas, 62 
previewing, 59 
publishing, 109 
saving, 47 

project manager, 18, 141 
collapse folder, 40 
dialog box, 41 
docking, 41 
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expand folder, 40 
hide, 41 
show, 41 
using, 40 

project properties 
auto-rotate, 110 
copyright information, 112 
initial vista, 111 
orbit field, 110 
player size, 110 
setting, 109 

project toolbar, 26 
publish, 142 
publishing, 109 

Q 
quick preview, 142 
QuickTime, 142 
QuickTime files, 39 

R 
Reality Studio 

components, 16 
features, 14, 30 

remote path, 118, 142 
specifying, 120 

RSD file, 142 

S 
saving projects, 47 
scenes, 142 
ScreenElement, 125 
scripted movie, 142 
SlideShowTexture, 125 
sounds, 32, 64, 77, 87, 143 

adding in 3D mode, 77 
adding in overlay mode, 78 
edit properties in 3D mode, 87 
edit properties in overlay mode, 87 
node, 127 

system requirements, 12 
Adobe Photoshop, 13 

hard disk space, 13 
RAM, 12 
web browsers, 13 

T 
target element 

setting up, 91 
target group 

setting up, 91 
toolbars, 25 

export project toolbar, 28 
insert objects toolbar, 29 
project toolbar, 26 
vista toolbar, 27 

tools menu, 23 
transition type 

cut, 102 
pan, 102 
zoom, 102 

trigger element 
setting up, 90 

troubleshooting, 130 

U 
uploading, 116 

local server, 116 
remote server, 117 
Zoom Image Server, 116 

URL links, 32 
URLs, 143 

linking elements, 105 
linking vistas, 102 

V 
view menu, 22 
view modes, 33 

3D, 17, 33 
changing, 34 
flat, 17, 33 
overlay, 17, 33 

viewpoint, 143 
viewport, 16, 143 
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displaying vistas, 62 
vista links, 143 

creating, 95 
vista toolbar, 27 
vistas, 32, 61, 79, 126, 143 

adding, 46, 62 
displaying in viewport, 62 
editing media files, 92 
editing properties, 79 
linking, 48 
linking elements, 105 
linking URLs, 102 
node, 126 

VRML, 123, 124, 144 
supported nodes, 126 

W 
warping, 144 
WAV file, 144 
WAV files, 39 
windows menu, 24 
world, 144 
world map, 18, 144 

background image, 43 
docking, 43 
hide, 43 
show, 43 
using, 42 

WRL files, 128 

Y 
yaw, 101, 145 

Z 
zoom, 102 
Zoom Image Server, 116, 119, 122 

uploading, 116 
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